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INTRODUCTION 

. Localized flooding and road damage can occur if drainage systems are not properly 

designed. The Utah Department of Transportation (UDOT) had the HYDRAIN computer library 

standardized on the U.S. Federal Highway Administration (FHWA) for conducting drainage 

calculations. However, this suite of computer programs is DOS-based and can be difficult to use 

effectively by consultants and UDOT engineers. In addition, HYDRAIN does not provide a 

conventional geographical information system (GIS) module for estimating watershed 

parameters. The HYDRAIN software currently available does not interface directly with the 

MicroStation Computer Aided Design (CAD) system being used throughout UDOT. The 

Hydraulics Division believes that productivity and accuracy could be increased by improving the 

culvert module and by identifying an improved hydraulic design software program. 

Therefore, this project was initiated to develop and select advanced computer programs 

to improve roadway hydraulic and hydrologic design tools available for use by UDOT engineers 

and consultants. The development and selection of such computer software that uses engineering 

analysis and interactive graphics is expected to reduce design and production times and improve 

quality control. 

PROJECT OBJECTIVES 

Project objectives were developed under the guidance of the UDOT Technical Advisory 

Committee (TAC). Members of the TAC for the project included: 

Name Organization Telephone 
Brvan Adams UDOT, Central Hydraulics (801) 965-4231 
Doug Anderson UDOT Research and Development (801) 965-4377 
Steve Bartlett UDOT Research and Development (801) 965-4377 
Abby Fallahi (UDOT Lead) UDOT, Central Hydraulics (801) 965-4693 
Bill Gedris FHW A, Utah Division (801) 963-0182, Ext. 243 
Skip Hudson MK Centennial (801) 268-9805 
Gerald Robinson UDOT, Region 3 Hydraulics (801) 227-8062 
Denis Stuhff UDOT Central Hydraulics (801) 965-4231 

The original scope of work for the project was established in July 1998. The general 

objectives of the project follow: 



1) Produce a prototype module for the analysis of culvert hydraulics, including enhanced 

functionality requested by UDOT. 

2) Survey the functionality of the Arc View GIS software for application to hydrologic 

estimates. 

SPECIFIC OBJECTIVES AND TASKS 

Objective 1: 

Produce a prototype module for the analysis of culvert hydraulics and energy dissipaters. 

Task 1: Develop a prototype computer module for culvert hydraulics that incorporates the 

specific functionality requested by UDOT hydraulic engineers, including adjusted 

invert, inlet control, outlet control, critical flow, noimal flow, full barrel flow, water 

surface profiles, and energy dissipaters. 

Task 2: Provide a user's manual and training for computer module. 

Task 3: Provide beta testing and focus group critique of the software products. 

Objective 2: 

Survey the functionality of the Arc View GIS software for application to hydraulic design. 

Task 1: Conduct a survey of features of Arc View as they relate to the use of digital terrain 

maps (DTMs) for estimating runoff and stream flow conditions for culvert design. 

Task 2: Present a summary of features that would be most useful for UDOT design 

engineers. 

REVISED OBJECTIVES AND TASKS 

Work progressed on the tasks, and presentations were made at two TAC meetings during 

summer and fall 1998. A workshop was held at a University of Utah computer laboratory in 

October 1998 for a group of UDOT hydraulic engineers to critique the prototype model. 
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At a TAC committee meeting on Jan. 22, 1999, two presentations were made: 

1) Features of Arc View for potential use by UDOT for hydraulic design. 

2) Revisions to the prototype hydraulic model based on recommendations from the fall 

workshop. 

The TAC engaged in prolonged discussions on the use of Arc View and other GIS products, 

and decided that it would be impractical for each UDOT hydraulic design engineer to become 

sufficiently skilled in the use of Arc View to apply it to their day-to-day activities. The committee 

members believed that GIS software specifically tailored for hydraulic design was available 

commercially. The TAC committee recommended a shift of the remaining project resources as 

follows: 

1) Discontinue work on the prototype hydraulic model (Objective 1). 

2) Discontinue work on the assessment of Arc View (Objective 2). 

3) Conduct a survey of the commercial GIS software products available specifically for 

hydraulic design (New objective). 

The new objective was further defined as follows: 

Objective 3: 

Survey hydraulic design software products that have the potential to interface with UDOT 

roadway design procedures and standards and recommend one for use by UDOT. 

Task 1: Conduct a survey of hydraulic software products that currently are available and 

have the potential to support UDOT roadway design procedures and standards. 

Task 2: Present a summary of features of selected software products and recommend use of 

one for UDOT. 
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CULVERT HYDRAULICS PROTOTYPE MODEL 

UDOT WORKSHOP 

The fall 1998 workshop, held in the Engineering Computer Laboratory at the University 

of Utah, was conducted for the Utah Department of Transportation and covered the following 

topics: 

Software features of the culvert model 

Prediction of scour at a structure outlet 

Design of internal and external energy dissipaters 

Hydraulic jump 

REGIONAL VIDEO CONFERENCE 

When Project Objective No. 1, Development of a Culvert Module, was about 50 percent 

complete, a teleconference was presented by Dr. Grenney to demonstrate the new computer 

modules, as well as to get focus group critique and feedback from practicing design engineers on 

how the modules could be improved. The Utah, Wyoming, and N.D. Departments of 

Transportation participated in the eight-hour video conference. Topics included: 

Summary of the new modeling processes being implemented. 

Review of the fundamentals of flow through culverts and demonstration of model 

features for: 

Free surface flow 

Hydraulic jump 

Water surface profiles 

Demonstration off eatures of the new Culvert Model, including: 

Roadway Properties Window 

Culvert Properties Window 
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Flow Properties Window 

Results Window 

Demonstration of new features for filing, printing, and data sharing. 

Demonstration of features for the Energy Dissipater Module, including: 

Scour hole 

Internal dissipaters 

External dissipaters 

Hydraulic jump 

The workbook for the teleconference, which includes a discussion of the fundamental processes 

upon which the Culvert Model is based, is provided as Appendix A 

The Prototype Culvert Module is a tool for calculating information about flows in open channels 

and closed barrels commonly used for culverts, including: 

The shape geometry for sixteen standard shapes 

The hydraulic properties of a user-defined shape as well as the standard shapes 

The water surface profile for a specified upstream or downstrea~ boundary condition. 

The User's Manual for the Prototype Culvert Module is presented in Appendix B 

The source code for the computer module is presented in the last Appendix of this report 

(Appendix E). 
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SURVEY OF GIS TYPE HYDROLOGY MODELS 

GENERAL SURVEY 

A survey of potential software products was made using the Internet. A summary of 

software products, including short descriptions of applications and features that were screened out 

from further investigated is presented in Appendix C. 

Software products that were evaluated in depth included: the Surface Water modeling 

System (SWMS), RMS (River Modeling System), GEOP AK Drainage, Storm Works, and WMS 

(Watershed Modeling Program). 

SMS (Surface Water Modeling System) 

This program was recommended by the FHW A as a two-dimensional modeling program. 

It was developed by the Engineering Computer Graphics Laboratory at Brigham Young 

University (BYU) (HYPERLINK http://ecgl.byu.edu/index.html http://ecgl.byu.edu/index.html) 

and is marketed and supported by BOSS International (http://www.bossintl.com). The software 

models the water surface elevation, flow velocity, contaminant transport and dispersion, and 

sediment transport and deposition for complex two-dimensional horizontal flow problems. 

RMS (River Modeling System) 

This program, marketed by BOSS International, is used to compute water surface profiles 

for modeling bridges, culverts, spillways, levees, bridge scour, floodway delineation and 

reclamation, stream diversions, split flows, and channel improvements using the U.S. Army 

Corps of Engineers HEC-2 and HEC-RAS water surface profile models (see Appendix D) in 

AutoCAD (http:/ /www.bossintl.com). 
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GEOPAK DRAINAGE 

This program module, which is part of a civil engineering suite of products, is used to 

design, analyze, and visualize storm water flow, with drainage features integrated with road and 

site design tools. The program can handle multiple drainage networks, comprising any number of 

topologically-connected areas, inlets, pipes, and ditches. It uses the MicroStation graphics 

environment for the definition, design, and review of drainage systems 

(http://bentley.com/products/ ceproducts/). 

STORMWORKS 

Intergraph's Storm Works, which integrates with a suite of other Intergraph civil 

engineering applications, is a comprehensive program for surface water collection, transport, and 

disposal. The program utilizes 3-D modeling and interactive graphics 

(http://www.intergraph.com/iss/products/civil). 

WMS (WATERSHED MODELING PROGRAM) 

The WMS software provides a comprehensive environment for hydrologic analysis of 

watershed systems. Developed in cooperation with the U.S Army Corps of Engineers Waterways 

Experiment Station and marketed and supported by BOSS International 

(http://www.bossintl.com), WMS provides graphical tools for use in delineation of watersheds 

and flood plains. The U.S Army Corps of Engineers HEC-1 and the U.S. Soil Conservation 

Service TR-20 hydrologic routing programs (see Appendix D) may be set up and viewed in a 

user-friendly graphical environment. Interfaces to the USGS National Flood Frequency program 

and the Rational Method Equation provide other modeling options 

(http://ripple.wes.army.mil/software/). 
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DISCUSSION 

Results of the evaluation of the software packages were presented to the TAC at a 

meeting at Utah State University. At this meeting, two programs, Storm Works and GEOPAK 

Drainage, were selected for an in-depth review and evaluation. Complete features of the software 

are presented in Appendix D, Chapter 1 for GEOP AK Drainage and in Appendix D, Chapter 2 for 

Storm Works. 

Procedures that were established to evaluate the software products included: 

Identification of the purpose of the software 

Demonstration of the software by the software developer 

Testing of the software using a known hydrologic design 

Evaluation of the characteristics and features of the software, including: 

Ease of learning 

Functionality 

Applicability to the task 

Availability of technical support 

A summary of the features, approaches, and functionality was developed to illustrate 

differences between StormWorks and GEOPAK Drainage. Various features and approaches 

presented by these models were compared and contrasted. 

Platform: 

GEOP AK Drainage is invoked from a 2-D MicroStation Design file, whereas 

Storm W arks can work on two-dimensional and three-dimensional design files. Three­

dimensional design files off er greater leverage for designing a drainage model. 

Surface/Geometric data: 

The Surface/Geometric data define the spatial extent and topological features of a 

drainage basin and, as such, is the first step in a design process. GEOP AK Drainage uses TIN 
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files to store terrain data, while Storm Works stores surface data as either a DAT file, a DTM file 

or a TIN file. 

In the design of a drainage network, roadway alignments, vertical profiles, and Digital 

Terrain Models (DTMs) play an important part. GEOPAK Drainage is closely integrated with 

other GEOP AK civil engineering design software such as GEOP AK Bridge (modeling and 

design), GEOPAK Survey (survey data handling), and GeoTrain (digital terrain modeling). In 

similar fashion, terrain files are interchangeable between Storm Works, InRoads (transportation 

design), Site Works (site design), In Water (water distribution), InSewer (wastewater collection) 

and other Intergraph products. Therefore the use of Storm Works may be preferable if terrain 

models have already been developed using other Intergraph software such as InRoads. Surface 

files are saved with the extension .dtm and geometry files are saved with the extension .alg in 

InRoads. These are the same files used to define the basin in Storm Works. 

Hydrologic features: 

Rainfall Data: For rainfall data, Storm Works uses intensity-duration frequency tables or 

rainfall-time of concentration or intensity equations for obtaining rainfall data. GEOP AK 

Drainage also uses intensity-duration frequency tables. In addition, GEOP AK Drainage has a 

wide range of equations from which to calculate rainfall intensity, including: 

i= f{a,b, c,Tc} 

i= f{a,b,c,frequency,Tc} 

i= f{a,b,c,ln[tc]} 

Peak Runoff: GEOP AK Drainage uses the rational method for peak runoff computations and 

frequency dependent peak factors for runoff coefficients. Storm Works uses the modified rational 

formula or the SCS methodology. 

Land Characteristics: Land uses within a project can be assigned in GEOP AK Drainage. 

Thus land can be categorized as grass, commercial, pavement, building, industrial, etc. As 

drainage areas are delineated, software determines the proportion of land uses, computes 
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subsequent runoff coefficients, and automatically assigns the hydrologic parameters for the 

drainage areas. The approach used in Storm Works is slightly different. In Storm Works, the type 

ofland ?over-asphalt, concrete, sandy lawn, clay, roofs, etc., can be selected along with their 

corresponding runoff coefficients. The former approach is quite generalized, whereas the latter 

approach is more down-to-earth and well-defined for most situations. 

Drainage Area Parameters: The computational method used for drainage area by 

Storm Works is either the modified rational formula or the SCS Unit hydro graph method. 

GEOP AK Drainage uses the rational method. 

Time of Concentration: The time of concentration, Tc, can be determined using either the 

Kirpich or FAA methodologies in Storm Works. In GEOPAK Drainage, the value of Tc is input 

directly. 

Hydraulic Features: 

Channels: In Storm Works, the channel can be designed by shape, trapezoidal, V-shaped 

or rectangular. Additionally, the channel material such as concrete, earth, or wood can be 

specified. In case of GEOP AK Drainage, channels are designed either by fixed geometry or based 

on cross-section. Therefore, trapezoidal or irregular ditches can be designed, but the material 

cannot be specified. Slope and velocity constraints can be defined in both models. In addition, 

GEOP AK Drainage can set constraints on the channel rise. 

Pipes: Both models provide options for the type of pipe and the material used. In the case 

of Storm Works, the software automatically displays error flags if design limitations are exceeded. 

In both programs, pipe and ditch profiles can be created showing hydraulic and energy gradelines. 

Flow equations: GEOPAK Drainage uses the Manning flow equation while Storm Works 

offers a choice between the Manning, Darcy-Weisbach and Colebrook-White equations. It should 

be noted that in Storm Works, pipes and culverts are designed using the Darcy-Colebrook 

equation, while open channels and gutters are always designed using the Manning equation. 



Pumps: Pump parameters can be specified and included in the drainage design in the case of 

Storm Works while GEOPAK Drainage does not have such capability. 

Management Capabilities: 

Both GEOP AK Drainage and Storm Works offer extensive reporting facilities. The 

reporting capabilities of GEOP AK Drainage are superior compared to Storm Works. Storm Works 

offers queried reports whereas customized reports can be generated using GEOP AK Drainage. 

This format can be saved for reuse. Storm Works has a management tool that can be used to 

monitor the installation and service dates of selected structures. The reporting capabilities of 

Storm Works can be enhanced if it is used in conjunction with DraftW orks, an Intergraph drawing 

utilities package provided in its civil engineering software package. 

RECOMMENDATIONS 

A workshop was held at Utah State University to present results of the Project Objective 

No. 3, Survey and Recommendation of Hydraulic Design Software. A demonstration of the 

features of the two software packages selected for final review (GEOPAK Drainage and 

Storm Works) was presented. 

Pros and Cons of the software were analyzed. It is worth noting here that both 

Storm Works and GEOP AK Drainage offer extensive capability and, as such, neither are inferior 

to the other. An important factor discussed was that UDOT uses Inroads, an Intergraph product 

for designing their roadways. It was thought that the digital terrain models developed using 

Inroads could be directly input into Storm Works precluding the need to recreate terrain maps. 

This also would entail uniformity among the various departments in UDOT. 

After discussion and questions, Storm Works was selected as the preferred software 

program for use by UDOT primarily because of its connectivity with the other design packages 

offered by Intergraph. 
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APPENDIX A 

TEL 8 TELECONFERENCE ON 

Culvert and Energy Dissipator 

Design Computer Modules 



TEL8 TELECONFERENCE 

Preview of the next release of the 
FHWA HYB 

Culvert and Energy Dissipater Design Computer Models 

Back~round. 
Dr. Grenney is currently leading a project to reprogram the FHW A HY8 Culvert and Energy Dissipator 
Design Computer Modules. The project is about 80% complete. Dr. Grenney is offering this conference in 
order to demonstrate the new computer modules, as well as to get feedback from practicing design 
engineers on how the modules can be improved before final release. 

Topics 
1) Summarize the new modeling process being implemented. 

2) Review the fundamentals of flow through culverts and demonstrate the model features for: 
• Free surface flow 
• Hydraulic jump 
• Water surface profiles 

3) Demonstrate features of the new Culvert Module 
• Roadway Properties Window 
• Culvert Properties Window 
• Flow Properties Window 
• Results Window 

4) Demonstrate new features for Filing, Printing and data sharing. 

5) Demonstrate the features for the Energy Dissipator Module 
• Scour hole 
• Internal dissipators 
• External dissipators 
• Hydraulic jump 

p rol!ram 
Day 1 

8:00- 9:00 Teleconference Testing and setup 
9:00 - 10:30 Presentations on Topics 1 and 2 
10:30 -10:45 Break 
10:45 -12:00 Independent work at each site. Dr. Grenney will be available to answer questions 
12:00 - 1:00 Lunch 

1:00 - 3:00 Presentations on Topics 3 and 4 
3:00 - 3:15 Break 
3:15 - 4:30 Independent work at each site. Dr. Grenney will be available to answer questions 

Dav2 
8:00 - 8:30 Teleconference Testing and setup 
8:30 - 10:30 Open discussion and presentations on Topic 5 
10:30 -10:45 Break 
10:45 -12:00 Independent work at each site. Dr. Grennev will be available to answer questions 
12:00- 1:00 Lunch 

1:00 - 3:00 Open discussion, bug reports, suggestions for improvements. 
Adjourn 
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Site Requirements 
Each site must provide at least one PC running Window 95 for use by the students in the vicinity of the 
teleconferencing room. 

Conference Materials 
Software will be sent to each site several days before the conference. The software should be installed and 
running prior to the start of the conference. 

Each site will provide their own copies of the following FHW A manuals for the conference participants to 
refer to: 

HEC 15, Hydraulic Design of Highway Culverts 
HEC 14, Hydraulic Design of Energy Dissipators for Culverts and Channels. 

Conference Cost 
$100 per site should be sent to the Cynthia Prante at the Utah Transportation Center, Utah State University, 
Logan, UT 84322-8200 in order to cover operating and material costs. 
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INTRODUCTION 

DEFINITION OF TERMS 

List of Symbols 

Following is the list of symbols used in this manual. 

A: Cross-sectional area of the water in a channel/culvert. 

Dr: The rise of the cross section of a channel/culvert. 

Ds: The span of the cross section of a channel/culvert. 

D1: The distance from the top of fill in the bottom of the channel/culvert to its top. 

Dr: The depth of the fill in the bottom of the channel/culvert. 

E: The energy head (Y +HP+ Hv). 

Ei: The energy head just inside the barrel at the inlet. 

Eu: The energy head just upstream from the headworks. 

F: Froude number. 

g: Acceleration of gravity. 

H: Hydraulic head (Y + Hp)-

Hi: Hydraulic head just inside the inlet. 

H0 : Hydraulic head just inside the outlet. 

HP: Pressure head. 

Hpi: Pressure head just inside the inlet. 

HP0 : Pressure head just inside the outlet. 

Hv: Velocity head. 

H vi: Velocity head just inside the inlet. 

Hvo: Velocity head just inside the outlet. 

hi: Head loss at the inlet. 
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Ki: Minor loss coefficient at the inlet. 

L: Slope distance from the inlet to some point along the channel/culvert. 

L1: Length of hydraulic jump. 

L0 Slope distance from the inlet to the outlet. 

n: Manning's roughness coefficient. 

n0 : Composite Mannings roughness coefficient 

P: Wetted perimeter. 

Q: Flow. 

Qp8 : Flow per barrel in a multi barrel culvert. 

R: Hydraulic radius. 

Se: Slope of the energy grade. 

S0 : Slope of the bottom of the channel/culvert. 

T: Top width of the water surface. 

V: Water velocity. 

X: Horizontal distance from the inlet to some point along the channel/culvert. 

X0 : Horizontal distance from the inlet to the outlet. 

Y: Depth of water. 

Y1: Lower conjugate depth. 

Y2 : Upper conjugate depth. 

Ybar: The distance from the water surface to the centroid of the wetted area. 

Y0 : Critical depth. 

Yi: Depth of water just inside the inlet. 

Y ru11 : The depth of water when the section is full (equal to D1) 

Y0 : Normal depth. 

Y0 : Depth of water just inside the outlet. 

Y iw: Tail water depth. 
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Yu: Depth of water upstream from the culvert inlet. 

z: Run over rise of the slope of the side of a channel/culvert. 

m: Specific (unit) weight of water. 

Figure 1 show three typical cross sections. The Ellipse is defined by the rise (D,) and span (D,). 
The Trapezoid is defined by the span (D,) equal to the bottom width and the run-over-rise for the 
sides (z). The Rounded Triangle is defined by the span (D,) at the point where the parabolic 

Figure 1. Typical cross sections for channels and culverts. 

bottom becomes tangent to the sides of the triangle and the run-over-rise of the sides of the 
triangle (z). For an open channel, the rise (D,) is the maximum depth before the flow overtops 
the sides. 

General Depth Relationships 

Figure 2 shows the longitudinal profile of a typical culvert on a mild slope. "Dr" is the rise of 
the culvert section. "Dr· is the distance from the top of the fill material in the bottom of the 
culvert to the top of the culvert. "Yu" is the depth of the water just upstream from the inlet. In 
this example the culvert is on a mild slope and so the normal depth (Y0 ) is greater than the 
critical depth (Ye)- The water surface drops from Yu to Y0 as it passes through the inlet due to 
energy loss through the headworks. The flow proceeds downstream at normal depth until it 
nears the outlet. The tail water (Y tw) is lower than the critical depth, and so the water surface just 
inside the outlet (Y0 ) dips through critical depth. 
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Figure 2. Typical culvert longitudinal profile on a mild slope. 

The computer module contains a user option to restrict the depth just inside the outlet (Y0) from 
ever becoming less than (Ye+ D1)/2. 

Figure 3 shows the longitudinal profile for a culvert on a steep slope. The critical depth (Ye) is 
greater than the normal depth (Y0 ). The upstream depth (Yu) dips rapidly to critical depth. From 
there it dips slowly towards the normal depth as an S2 curve. It is assumed that the depth just 
inside the inlet (Yi) is equal to the critical depth. 

Figure 3. Typical culvert longitudinal profile on a steep slope. 

Figure 3 shows the tail water (Y iw) greater than the full flow depth of the culvert (Y ruu and D1). It 
is assumed that the hydraulic head just inside the outlet (H0 ) equals the depth of the tail water. 
Because Y0 is limited to the depth of the barrel, a pressure head (Hp0 ) develops just inside the 
outlet equal to the difference between Y tw and Y0 • Full barrel flow occurs upstream until the 
pressure head diminishes to zero at which point free surface flow occurs. An S 1 backwater 
curve will extend upstream. 

The depth upstream is nearly normal and must cross the critical depth in order to meet the 
backwater curve. Consequently, a hydraulic jump will occur with lower conjugate depth about 
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equal to normal depth. The position of the jump will be at the point where the upper conjugate 
depth meets the backwater curve. 

STEADY UNIFORM FLOW 

Mannings Formula 

Composit Roughness Coefficient 

Option 1: 

Option 2: 

Option 3: 

Full Barrel Flow 

Mannings equation is used for full barrel (pressure) flow. 
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Hydraulic Jump 

Froude Number. 

Where Yh is the mean depth defined by: 

Energy Equation (Bernoulli Equation). 

Momentum Equation. 

When the upper conjugate depth exceeds Dr then the resulting pressure head (Hp2) is calculated 
by: 

H _ Ml -Mf 
p2 - A 

f 

where Mr and Ar are the momentum and cross sectional area at full barrel flow respectively. 
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Length of the Hydraulic Jump (L ,1. 

The length of a hydraulic jump is estimated by empirical factors obtained from field observations 
(King and Brater, Handbook of Hydraulics; US Bureau of Reclamation, Engineering Monograph 
25, "Hydraulic Design of Stilling Basin and Bucket Energy Dissipators." 

where ~ is a factor defined in Table 1 and Y 2 is the upper conjugate depth. 

Channel Slope Froude >=4 Froude > 3 Froude > 2 Froude > 1 
0.00 6.15 5.54 4.99 4.49 
0.05 5.20 4.68 4.21 3.79 
0.10 4.40 3.96 3.56 3.21 
0.15 3.85 3.46 3.12 2.81 
0.20 3.40 3.06 2.75 2.48 
0.25 3.00 2.70 2.43 2.19 
Table 1. Factors G3) for estimating the length of a hydraulic jump based on channel slope and 

Froude number. 

HEAD LOSS AT THE INLET 

FHWA Hydraulic Design Series No. 5, "Hydraulic Design of Highway Culverts." 

Unsubmerged (form 1): 

Y, =Y, +H,, +D,, ~;s r -~S 0 

Unsubmerged (form 2): 

Y, =D'1~:s r 
Submerged: 
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Minor loss at the inlet: 

(v.2) h-=K- - 1 

I I 2g 

RECONCILING THE HEADWATER AND TAIL WATER WITH CULVERT 
BOUNDARY CONDITIONS 

Tail Water and the Culvert Outlet Boundary. 
The culvert outlet boundary is the condition just inside the outlet. It is assumed that the 
hydraulic head at the outlet boundary (H0 ) is equal to the depth of the tail water (Y 1w)-

A user option is provided that will prevent H 0 from ever being less than one half the sum of the 
critical depth and the depth to the top of the barrel: 

Headwater and the Culvert Inlet Boundary. 

"Headwater" is the water depth (Yu) just upstream from the culvert headworks (inlet). The 
"Culvert Inlet Boundary" is the hydraulic head (H;) just inside the culvert barrel. The head loss 
through the headworks (h) is the difference between the energy head upstream (Eu) and the 
energy head of the boundary (E;). 

The parameters of greatest interest to designers are usually the upstream depth (Yu) and the inlet 
head loss (h;). Two general methods are used for calculating this depth: 

1. Calculate Yu directly using empirical functions based on the flow rate (Q), the headworks 
configuration, and the type and size of culvert. 

2. Calculate the head loss through the headworks (h), and add it to the depth of flow at the inlet 
boundary (Y;). 

Method 1. 

FHWA Hydraulic Design Series No. 5, "Hydraulic Design of Highway Culverts" provides 
functions for calculating the upstream depth (Yu) directly based on the flow rate (Q), the 
headworks configuration, and the size of the culvert. The value of Yu determined by this method 
is referred to as the "Inlet Control" depth. 

The head loss (h;) can be estimated by the difference between Yu and the flow depth at the inlet 
boundary: 
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for a mild slope and 

for a steep slope. 

Method 2. 

The direct calculation of the head loss through the headworks (h) is performed using the 
appropriate formulas. A backwater profile is calculated from the outlet to provide a value for Yi 
at the inlet. The head loss (hi) is added to the depth at the inlet boundary (Y) to get the upstream 
depth (Yu)- The value of Yu determined by this method is referred to as the "Outlet Control" 
depth. 

If the backwater profile does not reach the inlet, than inlet control should occur. If the backwater 
profile does reach the inlet, then outlet control should occur. 
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Appendix B 

Prototype Culvert Module 
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ROADWAY CULVERT MODULE 

The ROADWAY CUL VERT MODULE is a tool for analyzing the hydraulic characteristics of a 
roadway culvert system. A "Roadway Unit" unit contains the data defining the roadway 
geometry and the hydrology including flows and tailwaters. A "Culvert Unit" contains the data 
defining a culvert barrel and associated headworks. A Roadway Unit may contain more than one 
culvert unit. 

Figure 1 shows the initial screen for the ROADWAY CULVERT MODULE. It contains four 
tabs across the top, and it is open to the first tab for the "Roadway" data. The remaining three 
tabs are for entering culvert data, and presenting the results in tabulated and graphical forms. 

THE ROADWAY PAGE 
The "Roadway" page contains three major sections. On the left is an open vertical panel used to 
identify the Culvert Units associated with this Roadway Unit. More than one Culvert Unit may 
be associated with a roadway . 

.l-1 CulvertApp 1111£1 
Eile Edit Caclulate Help Tools 

LRoadWay1 Road Way I Culvert1 I Tabulated Results I Graphed Results I 

~ 
l!I! 

jRoadWa_y Close All ..tJ Open All ..!.I 
~ '----''---' 

Road Embankment 

RoadWa_y RoadWay Wizard 

jculvert1 ..:] !Paved ..:] or 

Weir Coefficient 10.2 

Road Width 175 

At embankment 

Max. water surface elevevation 1120.6 

DownStream bed elevation 1100 

DownStream bed Station 1250 

UpStream bed elevation 1103.75 

UpStream bed Station j100 

Clear R oadW ay j 
Figure 1. The initial screen for the ROADWAY CUL VERT MODULE. 
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Roadway Input Data 
The section on the right contains right in Figure 1 contains three horizontal panels for roadway 
data: 

• "Road Embankment." 

• "Longitudinal Road Profile." 

• "Flow." 

Roadway Embankment Panel. The "Road Embankment" panel is shown expanded in Figure 
1. The following input data fields are provided on this panel: 
Figure 1. The Roadway page with the "Road Embankment" panel expanded. 

• A selection list for the type of road surface above the culvert. A "Weir Coefficient" is 
associated with the type of road surface. This coefficient is used to calculate the flow 
overtopping the road when the headwater elevation exceeds the elevation of the road. The 
user may directly input a value for this coefficient. 

• The "Road Width." 

• The "Maximum Water Surface Elevation." The model will flag a solution if the headwater 
elevation exceeds this limit. Future versions of the model will automatically calculate the 
minimum size culvert(s) needed to maintain the headwater elevation less than or equal to this 
"Maximum Water Surface Elevation." 

• The "Down Stream Bed Station and Elevation." This is the station and elevation of the point 
where the downstream embankment intersects the streambed. 

• The "Up Stream Bed Station and Elevation." This is the station and elevation of the point 
where the upstream embankment intersects the streambed. 

The Flow Panel. Figure 2 shows the Roadway page with the "Flow" panel expanded. Two 
drop-down selection boxes are provided at the top of the panel for declaring the headwater and 
tailwater conditions. Three options are available for each: 

• "Neglect." The energy of the approaching stream is neglected. The tailwater is low enough 
to prevent any downstream control. 

• "Input." The user inputs values for depth and velocity for each flow. 

• "Calculate." The user specifies the characteristics of the stream channel and the normal depth 
and velocity are calculated for each flow. 

In Figure 2 the user has elected to neglect the energy in the approaching stream. He/she has 
elected to calculate the tail water by specifying the characteristics of the channel downstream. 

The Flow Panel. The "Flow" panel provides input fields for four flows ranging from the lowest 
flow of interest to the maximum flow of interest. Results will be calculated for each of these 
flows. 
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In addition a "Q_Inc" (flow increment) field is provided. Results will also be calculated at this 
increment from low flow to maximum flow. In this example results will be calculated for flows 
ranging from 150 cfs to 1575 cfs in increments of 100 cfs. Results will also be calculated at the 
four input flows. 

r CulvertApp lllilm 
Eile Edit .Caclulate tielp Tools 

LRoac!Way1 Road Way I Culvert1 I Tabulated Results I Graphed Results I 

~ 
I~ 
l!. '------"c:.J 

Roac!Way 

j Culvert1 .:J 

-1111~-, 1111 ,, . , 

Clear Roac!Way I 

IRoac!Way 

Roac!Way Wizard 

Road Embankment 

longitudinal Road Profile 

Flow 

Flow..-----, 
Q 

Max j1575 

Design 11250 _ 

Typical~ 

Low~ 

Channel Details 

Wier Coeficients 

Figure 2. The Roadway page with the "Flow" panel expanded. 

Close All .!J Open All .!,) 

.!I 

.!I 
I+ 

The Tailwater Channel Characteristics. The user elected to calculate the tailwater conditions 
by selecting "Tailwater: Calculate" in the drop-down selection box as shown in Figure 2. As a 
result, four panels appear to accept the data for the downstream channel: "Channel Details," 
"Roughness Coefficients," "Sediment Details," and "Define Culvert Shape." 

The input data fields on these panels are similar to those in the FREE SURF ACE FLOW 
MODULE. Figure 3 shows the Roadway page with the panels expanded for the downstream 
channel data that will be used to calculate normal depths for the tailwater elevations. A rounded 
triangle has been specified for the downstream channel. The geometric parameters are shown in 
Figure 3. 
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/:

1 

CulvertApp l!llilf3 
Eile Edit Caclulate ,tielp Tools 

LRoadWa91 Road Way I Culvert1 I Tabulated Results I Graphed Results I· 

Close All .!:.I Open All .!) 
Channel Details 1+ ..:.I 

Slope:j'iim 

Jculvert1 ::] Wier Coeficients I+ 
Primar9 n: ~ Sides n: ~ ... 

Bottomn: ~ Sides H: ·~ft 

Sediment Details I+ 

Sediment Depth: ro--- ft 
. 

Define Chanel Shaee I+ 

jRounded Triangle ::::] (c:. Load I 
-Rounded Triangl" 

. ·. 

Side Run/Rise: )1 .· .. 

Max Depth:I1~ -ft 

Clear RoadWay I 
Width at Top of Is 

Parabola: · • · ft 
l.:J 

Figure 3. The Roadway page with the panels expanded for the downstream channel data. 

THE CULVERT PAGE 

Figure 4 shows the "Culvert" page with the "Define Culvert Shape" panel expanded. A 7' -2.25" 
x 5 ' -7 .25' pipe arch has been selected form the file of standard shapes. This is the same section 
that is used in the example in the "FREE SURFACE FLOW MODULE" section of this Users' 
Guide. 

Figure 5 shows the "Culvert" page with additional panels expanded for input data: "Roughness 
Coefficients," "Culvert Details," and "Sediment Details." These panels have been previously 
defined, and contain the same input data, as the example in the "FREE SURF ACE FLOW 
MODULE" section of this Users' Guide. 

Notice also that a data field is provided for the "Number of Barrels." The user may specify more 
than one barrel of this identical shape, slope and roughness for the "Culvert Unit" represented by 
this page. Two barrels have been specified in this example. The computer module simply 
proportions the flow among the barrels (e.g. 50% to each barrel in the example). Multiple barrels 
in a Culvert Unit are assumed to act independently - headworks conditions on one do not affect 
the headworks conditions on another. 
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/'2 CulvertApp ■lilEI 
Eile Edit .C.aclulate ]:ielp Tools 

LRoaclw'ay1 Road Way Culvert1 I Tabulated Results I Graphed Results I 

[I j ~ I lculvert1 
-~ ~-

RoadWay Number Culverts Selected: 
1 

Close All .!J Open AD .:!I 
R ouQhness Coeficients .:!I 

lculvert1 . 3 
!.=C=u==lv=er=t D=e=ta=ils==========~.!i 

Sediment Details i] 

.:J ~ Load 

PipeAr~h------------~ 

Rise: j5.6042 . ft Rb: 17.6875 ft 

Rt:j3.6146 ft B:12.1458 ft 

Span:! 7.2083 ft 

Re: 11 .8854 ft 

Number of barrels r:iJ' 

Dear RoadWay I 
Figure 4. The Culvert Page with the "Define Culvert Shape" panel expanded. 

/i:'CulvertApp lllila 
Eile Edit .C.aclulate t!elp Tools 

LRoadWay1 Road Way PipeArch I Tabulated Results j Graphed Results J 

jPipeArch Close All .!J Open All .:!I 

Number Culverts Selected: 
1 

Roughness Coeficients r+ 
Primary n: I 0. 01 50 Sides n: 10.0200 

..:l Bottom n: I 0. 0300 Sides H: 12.0000 ft 

Culvert Details r+ 
l~let 1103. 75 ft 

Elevation: . 
Length: I 150. 00 

l~let 1103. 75 
Station: Slope: I 0. 0250 

. Sediment Details r+ 
Sediment I 1 _ 0000 Depth: ft 

Add Culvert Head Works r+ 
r Default r FHWATable 

r Ki r FHWA Empirical 

Clear RoadWay . j 
Figure 5: The Culvert Page with selected culvert input data panels open. 
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In addition to the data required to define the Culvert Unit, data are required to define the 
headworks associated with each culvert barrel. All barrels in a Culvert Unit must have the same 
headworks and the conditions at one headworks do not affect the conditions at another. The 
"HeadWorks" panel in Figure 5 allows the user to select one or more methods for calculating the 
headworks energy losses at the inlet. 

• Default. Not defined in this version of the computer model and will probably be removed. 

• Ki. A minor loss coefficient. 

• FHWA Table. The formulas and tabulated coefficients in HDS-5. 

• FHW A Empirical. The fifth order polynomial representations of the FHW A Table data. 

Data fields are provided for the specific options selected by the user. For example, Figure 6 
shows the panel expanded for the FHW A Table method. The coefficients for a pipe arch with no 
bevels have been loaded from the standard table by means of the "Load Table" button. This 
completes the input data needed for the Culvert Unit. 

r' CulvertApp lllilm 
Eile Edit Caclulate )jelp Tools 

LRoadway1 Road Way PipeArch I Tabulated Results I Graphed Results I 

~ 
I~ 
~ '----___;_;::., 

Roadway 

jPipeArch 

Clear Roadway I 

IPipeArch 

Number Culverts Selected: 
1 

Add Culvert 

Delete Culvert 

Close All .!J Open All .!.l 
Roughness Coeficients .!.l 
Culvert Details .!.l 
Sediment Details .!.l 

_H_ea_d_W_o_rk_s __________ r♦ 

r Default 

r Ki 

p FHWA Table 

r FHWA Empirical 

FHWA Table Method·PA 31 in corner r CM 

FHWA Table·No BeveJ...----------, 

K Form 

10.oos r 
M 

p.ooo 
C 

10.o3s 
Sl,pe correction 

-0.50 

I ! ....... B-.. Load.Table ...... 11 

Figure 6. Culvert page with the panel for "FHW A Table" method expanded. 
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CAL CU LA TE RE SUL TS 

Figure 7 shows a pop-up menu containing the "calculate" item. This menu is obtained, after all 
data has been input, by clicking on the culvert icon with the right mouse button. Clicking on the 
"calculate" item will generate the output. 

E ;.)Menu 13 
Load Culvert 

·r Save Culvert 
Edit Culvert 

Edit HeadWorks 

· Calculate 

~ Cancel 

Culvert1 

Clear RoadWay I 

!::ielp Tools 
ay Culvert1 I Tabulated Results I Graphed Results I 

mber Culverts Selected: 
1 

Add Culvert 

Delete Culvert· 

Roughness Coeficients 

Culvert Details 

Sediment Details 

Figure 7. Pop-up menu for calculating the results. 

- □ X 

..!.I 

Close All .tJ Open All .!J 
.!1 
.!1 
.!1 
.!1 
.!1 
.!1 

Figure 8 shows the "Tabulated Results" page after the calculation. TotQ is the total flow, QPB is 
the Flow per Barrel, Ytw is the tail water depth, Yup! is the upstream depth due to inlet control, 
and YupO is the upstream depth due to outlet control. 

Figure 9 shows the "Graphed Results" page. The graph plots Yup! and YupO versus total flow. 

NOTE: THE CALCULATE FUNCTION, THE TABULATED RESULTS PAGE AND THE 
GRAPHED RESULTS PAGE ARE NOT PRODUCING THE CORRECT ANSWERS IN THE 
BETA 1.0 VERSION OF THE SOFTWARE. 
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,r-' CulvertApp l!lmlm 
Eile Edit .C.aclulate .l::lelp Tools 

LRoac!Way1 Road\.v'ay I Culvert1 Tabulated Results I Graphed Results I 

l!!!~'. l!!! . 
Jg 150 150 

TotQ QPB Ytw Yupl YupO Hil HiO 

Roac!Way 250 250 

I Culvert1 .:J 350 350 

-----'--~ 450 450 

0 

0 

0 

0 

0 

0 

0 

0 

0 

0 

0 

0 

0 

0 

n 

183799648, 4.272096157 3.83799648, 1.64558875, 

6.29120254!: 5.95353126!: 6.29120254!: 2.349183797 

9.33618545!:7.436871051 9.33618545!: 103946161, 

113961620:: a, 79400539:; 113961620:: 193864488E 

18.4711341 E 12.839221 OC 18.4711341 E 6.54946327, 

24.5610980S 17.5931434E 24.5610980S 8.80827617E 

29.79466247 21.6785469[ 29. 7946624710. 7494440[ 

31. 6660594£ 23.1393890:: 31. 6660594c 11. 4435586c 

39. 7860145!: 29.4779529!: 39. 7860145!: 14.455309BE 

48.92095947 36.6088371, 48.9209594717.8435306!: 

59.07090377 44.5320434!: 59.07090377 21.60821914 

70.23583984 53.2475700:: 70.23583984 25. 7493762c 

82. 4157714E 62. 7554206E 82. 4157714E 30. 26700401 

82. 41 57714E 62. 7554206E 82. 4157714E 30. 26700401 

550 550 

650 650 

725 725 

750 750 

850 •850 

950 950 

1050 1050 

1150 11150 -----1250 1250 

1250 1250 

Dear Roac!Way I 1 n 
• 

qi; h1 nhq4R> 71 n'i'i'iR77> qi; h1 nhq4R> 1'i 1 h1 nq~ 

Figure 8: Tabulated Results. 

Ji) CulvertApp l!lmlm 
Eile Edit .C.aclulate .l::lelp Tools 

LRoac!Way1 

l!!!.[§]· ! L! , . 

Roac!Way 

j Culvert1 .::J 

Clear R oac!W ay I 

Road\.v'ayl Culvert1 I Tabulated Results GraphedResults j 

TChart 

' /' 1 ,500 - - - - - - - - - - - - ~ - - - - - - - - - /- -: - - - -

1,400 - - - - - - - - - - - - ~ - - - - - - 1/~-- - - - _, - - - - - - -
1,300 - - - - - - · - - - - - - ~ - - - - ./_ - - - - - -:- - - - - - - -

' / ' 
1,200 - - - - - - - - - - - - - - 1-,,."- - - - - - - - - -:- - - - - - - -
1100 ____________ ).".'. ____________ ; _______ _ 

I // 1 I 

1,000 ---------/-{ -------------:--------
/ ' ' :~:.::~:~;-:_:I::::::::::::: I::::~~: 

700 ---I- -----~--------------:--------
600 I ' ' :: r : ; : ::: ::::::::: 
300 I-----------{--------------:--------

' 200- - - - - - - - - - - - - • - - - - - - - - - - - - - _,_ - - - - - - -

50 100 

Figure 9. Graphed Results. 
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Figure 10. Roadway Culvert Module Architecture 
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FREE SURFACE FLOW MODULE 

The FREE SURF ACE FLOW MODULE is a tool for calculating the following information about 
flows in open channels and closed barrels commonly used for culverts: 

• The shape geometry for 16 standard shapes. 
• The hydraulic properties of a user defined shape as well as the standard shapes. 
• The water surface profile for a specified upstream or downstream boundary condition. 

OPEN CHANNEL HYDRAULIC PROPERTIES 

Figure 1 shows the main screen for the FREE SURFACE FLOW MODULE. This screen 
contains two tabs at the bottom: one for calculating open channel hydraulic properties and the 
other calculating water surface profiles. 

r Free Sulface Flow ■lilEI 
Eile Options 

Close All :!]open All.!! 

Define Section Shai;ie r+ . -
jPipe Arch ..:1 C=-Load I 
rPipeArc,, 

Rise: ,5.6042 ft Rb: ,7.6875 ft 

Rt: 13.6146 ft B: 12.1458 ft 

Span: 17 .2083 ft 

Re: j1.8854 ft 

Sediment Details r+ 
Sediment ~ ft 

Depth: 

Section Sloi;ie and Flow r+ 
~-1 Depth: j2.01 22 ft 

Slope: lo .02501 

~ Q: j200 ft'/sec w Cl'liculare ~ j ClearAll t/.' I 
Open Channel Properties Surface Profile 

Figure 1: The main screen for the FREE SURFACE FLOW MODULE 

Input and Results Panels 
The Open Channel Properties page contains three sections: data input panels, results panels, and a 
graph panel for the cross section of the specified channel. 

Hydraulics for Open Channels and Culverts B-11 



For example in Figure 1 a 7'-2.5" x 5 ' -7.25" pipe arch has been selected in the "Define Section 
Shape" input panel. The parameters defining the geometry for the section were loaded from a 
data file of standard shapes. A sediment depth of one foot has been specified in the "Sediment 
Details" input panel. The graph on the right shows the cross section and indicates the sediment 
depth. 

The "Section slope and Flow" panel contains three fields. The slope of the channel goes into the 
"Slope" field. The remaining two fields are "Depth" and "Q" (flow). Only one of these fields 
may contain a non-zero value. If Q is specified ( e.g. 200 cfs) then the depth must be set to zero 
(erased by the little button). When the "Calculate" button is clicked, then the normal depth will 
be calculated (e.g. 2.0122 ft). If the "Depth" is specified then the flow, Q, will be calculated for 
that normal depth. 

Figure 2 shows the page after the "Define Section Shape," "Section Slope and Flow," and 
"Sediment Details" panels have been collapsed and the "Roughness Coefficients" and "Normal 
Flow Results" panels have been expanded. 

Ffree Surface Flow lllilEI 
~Eile Options 

Close All ..t.]Open All ..!J 
Define Section Sha12e ..!l 
Sediment Details ..!l 
Section Slo12e and Flow ..!l 
Roughness Coefficients r+ 

Primary n: I .01500 Sides n: 10.02001 

Bottom n: I: 03000 Sides H: 12.0000 ft 

----------Results----------

Normal Flow Results Ouput r+ 

Vn: 114.174 ft/sec Rn: 11.3242 ft 

An: 114.110 fl' Tn: 16.9338 ft 

Pn: 110.655 ft Ybar jo.9941 ft 

Compostt n: 10.02000 

Critical Flow Results Out12ut ..!l 
Maximum Flow Results Dut12ut ..!l Calculate ~ I Clear All ii.' 

Open Channel Properties Surface Profile 

Figure 2: "Roughness Coefficients" and "Normal Flow Results" panels. 

The "Roughness Coefficients" panel has input fields for three values of Manning's n. The 
"Primary n" is applied to the entire shape if non-zero values are not entered into the other fields. 
If a non-zero value is entered into the "Bottom n" field then this value replaces the "Primary n" 
for the flat bottom portion of the shape. If a non-zero value is entered into the "Sides n" then this 
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value replaces the "Primary n" for a distance up the sides equal to the value in the "Sides H" 
field. 

The "Normal Flow Results" panel presents the normal flow properties including: normal velocity 
(V n), wetted cross section area (An), wetted perimeter (P n), hydraulic radius (Rn), top width (T n), 
distance from the water surface to the centroid of the wetted area (Ybar), and the calculated 
composite Manning's n value. 

The normal flow, "Q" and normal depth "Depth" are presented in the "Section Slope and Flow" 
panel as shown in Figure 1. 

Figure 3 shows the page after the "Roughness Coefficients" and the "Normal Flow Results" 
panels have been collapsed and the "Critical Flow Results" and Maximum Flow Results" panels 
have been expanded . 

./t1Free Surface Flow llilf3 
Eile Options 

Close All .:t.lOpen All .!J 
---------- ---------- l.:J Normal Flow Results Ouput .!J 

Critical Flow Results Output r+ 
Yc:j2.8634 ft Y

0
:j10.137 ti/sec 

A
0

: 119.729 ti' Tc: ,6.1819 ti 

p 
0

: 112.522 ft y bar 11 .4432 ti 

Re: 11 .5756 ti 

Composit n: 10.01929 

Maximum Flow Results Output r+ 
Qmax= 1468.05 t1•tsec P: 117 .251 ti 

Y max= 14.3573 ft R: 11.5596 ft 

A: 126.905 ti' T: j2.6253 ft 

Ybar: j2 .3763 ti 

Composit n: jo.01967 -... Celculate ~ I Clear All t/! 

Open Channel Properties Surface Profile 

Figure 3. Critical Flow and Maximum Flow Results panels. 

The "Critical Flow Results" panel presents the same properties for critical flow that were 
presented in the previous panel for normal flow. The critical depth is presented at the top of the 
list (Yc)-

The "Maximum Flow Results" panel presents the same properties for the maximum normal flow 
that can be carried by this section at the specified slope and with the specified Manning's n 
values. "Qmax," is the maximum flow without an upstream pressure head or downstream control. 
Notice that the depth of the maximum flow (4.3573 ft) is less than the depth of full barrel flow: 
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(full barrel depth) = (rise) - (sediment depth) 

This wi!l be the case for all closed shapes. 

(5.6042) - (1.0) 4.6042 ft 

Functional Buttons. 

Calculate I 

Clear AU ti. I 

. Close All ..!J 

Open All :!.I 

)lfmd=tfflij@4fflJt 3 

The "Erase" button is used to erase the contents in the associated input field. 

The "Calculate" button triggers the computational algorithms that read the 
input data and generate the results. When the "Calculate" button is red the 
input data has been changed since the last time the button was clicked. In other 
words, the current results were not generated from the modified input data. 
Red means, "Stop from using the results until this button has been clicked." 
The button will tum green when it is clicked. Green means, "Go ahead and use 
the results, they have been generated from the current input data." 

The "Clear All" button clear all of the fields in all of the input and results 
panels . 

The "Close All" button closes all panels. 

The "Open All" button opens all panels. 

C2>Load 
The "Load" button opens a dialog box for accessing a file 
containing the geometric properties for standard shapes. 

WATER SURFACE PROFILES 

Figure 4 shows the "Water Surface Profile" page with the "Graphed Results" panel open. The 
algorithms calculate the water surface profile for the shape and flow conditions defined on the 
previous "Open Channel Properties" page. Either an upstream or downstream boundary may be 
selected. The water depth, hydraulic grade line and energy grade line are calculated and graphed. 

The Graphed Results Panel 

The "Graphed Results" panel has two sections. The lower half of the panel provides for the input 
data including fields for: 

• Declaring either an upstream or downstream boundary. 

• The boundary depth. 

• The boundary velocity. 
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• The length of the channel (slope length). 

• Minor loss coefficient. 

• Option for specifying that a downstream boundary must be greater than or equal to one half 
the sum of the critical depth and the rise of the section. 
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Figure 4. The Graphed Results panel on the "Water Surface Profile" page 

The top half of the panel displays a graph of the water surface profile resulting from the shape 
and flow characteristics in the "Open Channel Properties" page, and the data values at the bottom 
of this page. 

The graph in Figure 4 displays the results for the example shape and flow values previously entered in the 
"Open Channel Properties" page, and the values at the bottom of this page, namely: a downstream 
boundary depth of 5.5 feet, a length of 100 feet, match the hydraulic grade at the boundary, and require a 
downstream boundary not less than one half the sum of the critical depth and the rise of the section. 

The plot shows the profile from the inlet (upstream) on the left to the outlet ( downstream) on the right. The 
lower axis of the plot is aligned with the bottom of the channel - although we know that the channel bottom 
slopes down from left to right, our view is presented horizontally. 

The channel ( culvert) outlet is submerged. The top line extending the entire length of the channel is the 
energy grade line. The middle line is the hydraulic grade line. The lower line extending from about 55 feet 
downstream to the outlet is the depth of water at full barrel flow. The water surface profile can best be 
described by viewing the tabulated data along with the graphical display. 
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The Tabulated Results Panel 
Figure 5 shows the "Surface Profile" page with the "Tabulated Results" panel open. The graph 
on the right automatically shrinks to fit the page. The "Tabulated Results" panel presents the 
following information: 

Lx: The slope distance from the inlet. 

Y x: The water depth. 

PHx: The pressure head. 

VHx: The velocity head. 

Ex: The energy head (Yx + PHx + VHx). 

The inlet (upstream) boundary is assumed to be at normal flow. The channel is on a steep slope 
and therefore Y0 (normal depth) is less than Ye (critical depth) as displayed in the previous "Open 
Channel Properties" results panels. For the conditions in this example, downstream control will 
cause a hydraulic jump to occur in the barrel. 

The first row in the table displays the input downstream boundary values. The second row 
displays the boundary condition just inside the outlet. Notice that a pressure head exists equal to 
the difference between the external boundary depth and the full barrel depth. Also a velocity 
head has been calculated for the depth at the outlet (full barrel in this example). 

Starting at the outlet and moving upstream, the pressure head decreases until it intersects the top 
of the barrel at Lx = 55.1 feet. The depth of the water, represented by the middle line on the 
graph, is equal to the barrel depth while there is a pressure head. When there is no pressure head, 
the water depth coincides with the hydraulic grade. Free surface flow occurs at the point where 
the hydraulic grade intersects the top of the barrel, and a backwater curve extends upstream. The 
backwater curve intersects the upper conjugate depth of a hydraulic jump at Lx = 29.2 feet and Yx 
= 3 .95 feet. The jump extends to the lower conjugate depth, which is the normal depth, at Lx = 
14.6 feet. Normal depth extends then to the outlet. 
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Figure 5. The "Surface Profile" page with the "Tabulated Results" panel open. 

SUMMARY 

r♦ 

J 

Figure 6 is a schematic diagram of the interface structure for the FREE SURF ACE FLOW 
MODULE. The module contains two main pages identified by tabs at the bottom: the Open 
Channel Properties page and the Water Surface Profile page. 

The Open Channel Properties page contains seven horizontal panels that may be expanded or 
collapsed. 

• Define Section Shape: Input data fields for specifying the channel/culvert geometry. The 
user can access standard shape files for six types of shapes by clicking on the load button. 

• Sediment Detail: An input data field for the depth of sediment in the section. 

• Section Slope and Flow: Input data fields for the channel slope and a range of flow values. 

• Roughness Coefficients: Input data fields for three values of Manning's n: Primary n, 
Bottom n, and Sides n with associated distance up the sides from the bottom. 
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• Normal Flow Results: Output fields displaying ·the normal flow properties: depth (Yn), 
velocity (Vn), wetted perimeter (Pn), hydraulic radius (Rn), water surface top width (Tn), 
distance from the water surface to the centroid of the wetted area (Ybar), and the composite 
value of Manning's n (Comp-n). 

• Critical Flow Results: Output fields displaying the critical flow properties: depth (Ye), 
velocity (Ve), wetted perimeter (Pc), hydraulic radius (R:), water surface top width (Tc), 
distance from the water surface to the centroid of the wetted area (Ybar), and the composite 
value of Manning's n (Comp-n). 

• Maximum Flow Results: Output fields displaying the properties for the maximum flow that 
can occur for this channel/culvert without an upstream pressure head: depth (Y max), velocity 
(V max), wetted perimeter (P max), hydraulic radius (Rmax), water surface top width (T max), 
distance from the water surface to the centroid of the wetted area (Ybar), and the composite 
value of Manning's n (Comp-n). For closed shapes, Y max will be less than the rise of the 
shape. 
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Figure 6. Schematic of the interface structure for the FREE SURF ACE FLOW MODULE. 
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Models Removed During Initial Screening 

ANNIE 
Interactive hydrologic and data management 

ANNIE is a program designed to help users interactively store, 
retrieve, list, plot, check, and update spatial, parametric, and time-series data for 
hydrologic models and analyses. Data are stored in a direct access file called a 
Watershed Data Management (WDM) file. Many hydrologic and water-quality 
models and analyses developed by the U.S. Geological Survey (USGS) and the 
Environmental Protection Agency (EPA) currently use WDM files. The WDM 
file provides users with a common database for many applications, thus 
eliminating the need to reformat data from one application to another. There is 
also an expanding library of subroutines for graphics, user interaction, and data 
storage and retrieval available to application programmers designing software 
utilizing WDM files. (http://flash.net/~scitech/freesoft.htm) 

AquaDyn 

AquaDyn allows the complete description and analysis of hydrodynamic 
conditions (e.g., flow rates and water levels) of open channels such as rivers, 
lakes, or estuaries. (http://waterengr.com/) 

BRANCH 

The Branch-Network Dynamic Flow Model (BRANCH) is used to simulate 
steady or unsteady flow in a single open-channel reach (branch) or throughout a 
system of branches (network) connected in a dendritic or looped pattern. 
BRANCH is applicable to a wide range of hydrologic situations wherein flow and 
transport are governed by time-dependent forcing functions. BRANCH is 
particularly suitable for simulation of flow in complex geometric configurations 
involving regular or irregular cross sections of channels having multiple 
interconnections, but can be easily used to simulate flow in a single, uniform 
open-channel reach. Time-varying water levels, flow discharges, velocities, and 
volumes can be computed at any location within the open-channel network. 
Streamflow routing and computation by the BRANCH model is superior to 
simplified-routing methods in open-channel reaches wherein severe backwater 
and ( or) dynamic flow conditions prevail. Typical uses of the model encompass 
the assessment of flow and transport in upland rivers in which flows are highly 
regulated or backwater effects are evident, or in coastal networks of open 
channels wherein flow and transport are governed by the interaction of freshwater 
inflows, tidal action, and meteorological conditions. Surface- and ground-water 
interactions can be simulated by the coupled BRANCH and USGS modular, 
three- dimensional, finite-difference ground-water flow (MODFLOW) models, 
referred to as MODBRNCH. (http://www.flash.net/~scitech/freesoft.htm) 
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CAP 

The Culvert Analysis Program (CAP) follows USGS standardized procedures for 
computing flow though culverts. It can be used to develop stage-discharge 
relationships for culverts and to determine discharge though culverts from high 
water marks. It will compute flows for rectangular, circular, pipe arch, and other 
nonstandard shaped culverts. (http://www.flash.net/~scitech/freesoft.htm) 

CHAN for Windows (Version 2.03) 

CHAN for Windows is a modeling system that generates runoff hydrographs for 
basins and performs hydrodynamic routings of that runoff through a surface water 
system comprised of lakes, ponds, channels, and drainage structures. CHAN 
features all of the most popular methods for computing runoff and advanced 
hydrodynamic algorithms to provide fast stable simulations. 
(http://www.aquarian-software.com) 

CHANNEL 

The CHANNEL program has six modules that automate design and analysis of 
open channels. It includes: HEC-15 flexible lining analysis, popup references that 
guide you through the input, context sensitive help, bends analyzed according to 
HEC-15 procedures, non-erodable linings that follow Ven Te Chow's text, 
cohesive and non-cohesive erodable analyses, best hydraulic section design, 
minimal lining cost design, and popup graphs to aid in soil parameter selection. 
(http://www.waterengr.com) 

Culverts (Part of Hydraulics Utility Programs) 

In the Culverts program, the culvert characteristics are entered, and a headwater 
vs. outflow rating curve indicating inlet or outlet control is produced. 
(http://waterengr.com) 

DCUH 
DCUH is a unit hydrograph program for the estimation of a unit graph from 
rainfall and discharge data. 
(http://waterengr.com) 
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DR3M 

The Distributed Routing Rainfall-Runoff Model (Version II) (DR3M) is a 
watershed model for routing storm runoff through a branched system of pipes and 
(or) natural channels using rainfall as input. DR3M provides detailed simulation 
of storm-runoff periods selected by the user. There is daily soil-moisture 
accounting between storms. A drainage basin is represented as a set of overland­
flow, channel, and reservoir segments, which jointly describe the drainage 
features of the basin. This model is usually used to simulate small urban basins. 
Interflow and base flow are not simulated. Snow accumulation and snowmelt are 
not simulated. (http://www.flash.net/~scitech/freesoft.htm) 

Flash20 (A pulldown version of TR-20) 

Flash20 provides a user friendly data input program for SCS's TR-20 hydrology 
software. Generates a TR-20 input file from TR-55 hydrology data computed with 
Flash55. Allows you to graphically connect drainage areas and route them 
through channels and structures. Flash20 will automatically run TR-20 for you 
too, with no input required. And because you are still using SCS's TR-20 method, 
reviewing agencies will accept your data without the hassles associated with using 
other software. 
(http://www.ramss.com/hydro.html) 

FlashSS (A pulldown version of TR-55) 

Flash55 is a hydrology program for PC-compatible computers. It performs SCS 
TR-55 method hydrology computation and report preparation with easy to use, 
pulldown menu user interface. Users can enter soil types, land uses, and areas, 
and the software selects the correct CN and percent of impervious area. The 
program also inputs elevations and flow lengths to automatically compute the 
watercourse slopes of Tc paths. An unlimited number of drainage areas, subareas, 
and Tc path segments are allowed. Total impervious area is also computed for 
each drainage area. Also transfers files from HYDROmate, TR-55 software for 
the HP48. (http://www.ramss.com/hydro.html) 

Flow Pro 2.0 

Flow Pro computes steady-state water surface profiles for many prismatic open 
channel shapes, including circular, rectangular, trapezoidal, triangular, u-shaped 
and tubular. It handles both subcritical and supercritical flow types, and includes 
several new tools for designing weirs, orifices, and underflow gates. Flow Pro 
also computes many useful flow and channel properties such as critical depth and 
slope, hydraulic radius and wetted perimeter, normal depth, and channel 
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roughness. It uses the Manning equation and numerical integration for state-of­
the-art accuracy, and accepts both English and SI units of measure. 
(http://www.europa.com/ ~psapps/vault.htm) 

Flow Tool 

FlowTool is a hydraulic calculator program for PC-compatible computers. 
FlowTool allows the solution of equations relating to pipe pressure, pipe gravity, 
weir, orifice, gutter, and channel flows. All equations may be solved for any 
variable, and partial solutions are performed if not enough information is 
provided. A range for a variable may also be specified, and multiple solutions will 
be calculated automatically to generate rating tables. Also the program includes 
Pipe Analysis, which checks all flow types and determines the controlling factor. 
(http://www.ramss.com/hydro.html) 

FLOWPROF 

FREQ 

FLOWPROF computes one-dimensional steady state water surface profiles in 
prismatic and transition open channels. 
(http://www.erols.com.cahh/) 

The program FREQ is a graphics-based LP3 flood frequency estimation program. 
Estimation is done by least squares. Features of the program are calculation of 
unbiases frequency factors and confidence limits for estimates. The program 
allows the user to alter the value of skew and/or peaks to years ratio. The effects 
of any changes can be monitired graphically. 
(http://www. waterengr .com/) 

GLSNET 

GLSNET, a regional hydrologic regression and network analysis using 
generalized least squares, uses an analysis of residuals technique to estimate a 
regional regression equation to predict flow characteristics at ungaged sites. The 
regression analysis assigns different weights to observed flow characteristics. 
These weights are based on record length, cross correlation with flow 
characteristics at other sites, and an assumed model error structure. 
(http://flash.net/~scitech/freesoft.htm) 
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Gully 

Gully is a program to compute gully control structure design parameters. 
(http://www. waterengr.comL) 

HEC-RAS 

HEC-1 

HEC-5 

The River Analysis System (RAS) is the first of the Hydrologic Engineering 
Center's Next Generation Software programs. This Windows-based water surface 
profiles program will replace HEC-2 and ultimately, HEC-6 and UNET. 
(http://www.waterengr.com/) 

HEC-1 is the U.S. Army Corps of Engineers flood hydrograph package for 
rainfall-runoff simulations. This program will produce runoff hydrographs for 
complex watershed networks incorporating reservoir and channel routing 
procedures. The program will allow various methods for calculating rainfall 
hyetographs, basin unit hydrographs, and watershed loss rates. 

HEC-1 v is a virtual memory hybrid version of HEC-1, developed by the Corps for 
evaluating extended hydrographs, with up to 1,000 data points. This can be 
invaluable for modeling storms of more than a few hours duration when small 
subareas, requiring short time steps, are involved. 
(http://www.waterengr.com/) 

The HEC-5 program is designed to simulate the sequential operation of a 
reservoir/channel system with a branched network configuration. Any time 
interval from one minute to a month can be used. Multiple time intervals can be 
used within a single simulation. Channel routing can be performed by any of 
seven hydrologic routing techniques. Reservoirs operate to: (1) minimize 
downstream flooding; (2) evacuate flood control storage as soon as possible; (3) 
provide for low flow requirements and diversions; and (4) meet hydropower 
requirements. Hydropower requirements can be defined for individual projects or 
for a system of projects. Pump storage operation can also be simulated. Sizing of 
conservation demands or storage can be automatically performed, using the safe 
yield concept. Economic computations can be provided for hydropower benefits 
and flood damage evaluation. Two editions of the HEC-5 package of programs 
are available: "overlayed" and "extended memory" (EM). While the basic 
programs are the same, the "EM' edition runs much faster and provides for 20 
reservoirs and 40 control points, whereas the "overlayed" edition provides for 7 
reservoirs and 15 control points. 
(http://www.waterengr.com/) 
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HEC-2 

This U.S. Army Corps of Engineers water surface profiles program has become 
the standard for FEMA floodplain evaluations and river channel design. The 
program runs in sub- or super-critical mode and has extensive bridge and culvert 
modeling capabilities. It will also model sideflow weirs, drop structures, and 
floodplain encroachments. 
(http://www.waterengr.com/) 

HEC-6 

This program is used for the evaluation of scour and deposition in rivers and 
reservoirs. It is an extension to the HEC-2 channel geometry model, incorporating 
suspended and bedload sediment data. Sediment gradation and inflow tables are 
input into the model, as well as long-term inflow hydrographs. The output 
identifies reaches and depths of sedimentation and channel scour. 
(http://www.waterengr.com/) 

HEC-FFA 

The HEC Flood Flow Frequency Analysis (FF A) program performs frequency 
computations of annual maximum flood peaks in accordance with the Water 
Resources Council "Guidelines for Determining Flood Flow Frequency," Bulletin 
17B. This edition replaces the previous HEC-WRC program ( date of last program 
release: February, 1995 (Version 3.1)). The program comes with a complete 
bound copy of the User's Manual. The program also comes with the U.S. Army 
Corps of Engineers' data storage system and GSS service drivers. 
(http://www.waterengr.com/) 

HSPEXP 

HSPEXP is an expert system for calibration of the Hydrologic Simulation 
Program -Fortran (HSPF). It interactively allows the user to edit the input uci file 
for the HSPF, simulate with HSPF, produce plots of HSPF output compared to 
observed values, compute error statistics for a simulation, and provide the user 
with expert advice on which parameters should be changed to improve the 
calibration. In general, the user will spend time repeating the cycle of simulate, 
compute statistics, see plots, get advice, and edit the parameters. 
(http:/ /flash.net/ ~scitech/freesoft.htm) 
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Hydraflow Hydrographs 

Hydraflow Hydrographs is a Windows-based rainfall-runoff and hydrograph 
development and routing model for complex watersheds. 
(http://www.waterengr.com/) 

HYDRAIN 

The HYDRAIN program includes: 

CDS - Culvert Design System 

This program provides the engineer with the option of hydraulic design of 
a culvert or hydraulic analysis of an existing or proposed culvert. It routes 
hydrographs and considers both ponding and overtopping. The design option 
automatically selects a culvert size and the number of barrels, based on 
engineering data, environmental constraints, and site geometry. The review option 
will·take the chosen culvert shape and size and will display hydraulic performance 
data for the selected culvert. 

HY-8 - Culvert Analysis Program 

Given the appropriate data, the program will compute the culvert 
hydraulics for circular, rectangular, elliptical, arch, and user-defined culverts. The 
logic involves calculating the inlet and outlet control headwater elevations for the 
given flow. The elevations are then compared, and the larger of the two is used as 
the controlling elevation. In cases where the headwater elevation is greater than 
the top elevation of the roadway embankment, an overtopping analysis is done in 
which flow is balanced between the culvert discharge and the surcharge over the 
roadway. In cases where the culvert is not full for any part of its length, open 
channel computations are performed. 

HydroCulv 

HydroCulv performs culvert hydraulic calculations to determine water surface 
profiles through culverts, based on culvert geometry data and boundary 
conditions. Output includes key results such as freeboard, head loss, inlet and 
outlet velocities, as well as depth and velocity profile information throughout the 
culvert. The output can be displayed in plots to aid in assessing the performance 
of the culvert over the range of boundary conditions and the sensitivity of results 
to certain variables. 
(http://www. waterengr.corn/) 
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HydroTech (V. 1.0) 

HydroTech provides several scientific and engineering tools required in the 
analysis and manipulation of historical hydrological and water quality data. 
Statistical analysis tools and utilities include: log Pearson Type III, plotting 
position formulas, descriptive statistics, hydrograph data viewers, water quality 
indexing, and fisheries stream flow requirements. 
(http://www.waterengr.com/) 

HYRROM 

HYRROM is an easy-to-use conceptual rain runoff model, with no requirement to 
understand the computing operating system or the structure of data files. The 
main use of a rainfall runoff model is to predict river flows from rainfall and 
evaporation data. In HYRROM, flows are predicted using a simple, realistic 
representation of the physical processes that govern water flow in a catchment. 
The model incorporates interception, soil, groundwater, and runoff stores, and 
includes some representation of the losses due to evapotranspiration. It can be 
calibrated manually or automatically using the built-in Rosenbrock optimization 
routine. The program is compatible with HYD AT A. Output is in the form of color 
screen graphics that can be sent to a plotter or graphics printer, if required. 
(http://www.scisoftware.com/) 

Meltsum 

Meltsum computes snowmelt from a degree-day model. 
(http://www.waterengr.com/) 

MLRP 

PRMS 

The Multiple Linear Regression Program (MLRP) follows the procedures of 
"Statistical Methods in Hydrology" (Beard, 1962). Major features of the program 
are automatic deletion of independent variables (according to importance), 
combination of variables to form new variables, transformation of variables, 
tabulation of the residuals from the prediction equation, and acceptance of input 
coefficients. The program comes with a complete bound copy of the User's 
Manual. 
(http://www.waterengr.com/) 

The Precipitation-Runoff Modeling System (PRMS) is a modular-design, 
deterministic, distributed-parameter modeling system developed to evaluate the 
impacts of various combinations of precipitation, climate, and land use on 
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streamflow, sediment yields, and general basin hydrology. Basin response to 
normal and extreme rainfall and snowmelt can be simulated to evaluate changes 
in water-balance relationships, flow regimes, flood peaks and volumes, soil-water 
relationships, sediment yields, and groundwater recharge. Parameter-optimization 
and sensitivity analysis capabilities are provided to fit selected model parameters 
and evaluate their individual and joint effects on model output. The modular 
design provides a flexible framework for continued model-system enhancement 
and hydrologic-modeling research and development. 
(http://flash.net/ ~sci tech/freesoft. htm) 

RAMSS' Hydraulic Model 

SAC 

The RAMSS' Hydraulic Model performs channel, basin, and structure routings 
for complex networks of structures. It allows analysis of scenarios not possible 
using static rating table-based software. Multiple basin designs can be analyzed 
where varying tailwaters control discharges. Discharge types include circular 
pipe, box culvert, risers, weirs, and exfiltration. 
(http://www.ramss.com/hydro.html) 

The Slope-Area Computation (SAC) program follows USGS standardized 
procedure for computing discharge by the slope-area method. 
(http://flash.net/~scitech/freesoft.htm) 

SCSCN 

The SCSCN is a storm runoff hydrograph model based on the SCS Curve Number 
method and NEH4. 
(http://www.waterengr.com/) 

SCSHYDRO 

SCSHYDRO is a rainfall-runoff model based on U.S Department of Agriculture's 
Natural Resources Conservation Service (NRCS) (formerly the Soil Conservation 
Service (SCS)) hydrologic procedures. This model is a replacement for TR-20. 
(http://www.erols.com/cahh/) 

SMADA 

SMADA for Windows is a complete hydrology program that includes a number 
of separate executable files. These programs work together to allow hydrograph 
generation, pond routing, storm sewer design, statistical distribution and 
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regression analysis, pollutant load monitoring, matrix calculation, and others. 
Extensive on-line documentation is available for all programs. These programs 
are useful in both classroom and professional applications. 
(http://www. waterengr .com/) 

STATS 

The ST ATS program is designed to reduce large volumes of time series data to a 
few meaningful statistics or curves. The program will perform the following 
analyses: (1) duration curves; (2) annual maximum events; (3) annual minimum 
events; (4) departures of monthly and annual values from respective means; and 
(5) annual volume-duration exchange of high and low events. Data to be used as 
input to this program can be provided from a data file, or the data can be accessed 
through HEC's Data Storage System (HEC-DSS). This latter capability provides 
for the analysis of output from other REC programs. The frequency analysis may 
be analytical for data that tends to follow a theoretical distribution, e.g., annual 
maximum daily flows; or graphical for those data that do not tend to follow any 
known distribution, e.g., regulated flows. The input data may be transformed to 
logarithms for the statistical analyses, if required. Program documentation 
consists of detailed input descriptions. 
(http://www. wateren gr.com/) 

SWMM43 

TOC 

TR-20 

SWMM43 is the latest version of the Rainfall Runoff Model developed by the 
U.S. Environmental Protection Agency. 
(http://www.waterengr.com/) 

TOC computes overland time of concentration suing a combination of the 
Kinematic Wave Formula and the Green & Ampt Method. The technique was 
developed and published by Dr. Akan and received an ASCE award as an 
"outstanding contribution to irrigation and drainage research and education." In 
terms of formulation, this program is the state-of-the- art in time-of-concentration 
methods. 
(http://www.erols.com/cahh/) 

TR-20 is the U.S. Department of Agriculture's Natural Resource Conservation 
Service (formerly the Soil Conservation Service) program for project formulation 
hydrology. 
(http://www.waterengr.com/) 
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TR-55 

UNET 

TR-55 is the U.S. Department of Agriculture's Natural Resource Conservation 
Service (formerly the Soil Conservation Service) rainfall runoff model. The 
primary functions of the program are for peak runoff computations using the 
Graphical Peak Discharge Method, The Tabular Peak Discharge Method, and 
Temporary Storage. Support functions include the computation of the runoff 
curve (CN), the time of concentration (Tc), and travel time through a subarea (Tt). 
(http://www.waterengr.com/) 

UNET (Version 3.1) was developed by the U.S Army Corps of Engineers. UNET 
simulates one-dimensional unsteady flow through a full network of open 
channels. In addition to solving the network system, UNET provides the user with 
the ability to apply several external and internal boundary conditions, including: 
flow and stage hydrographs; rating curves; gated and uncontrolled spillways; 
pump stations; bridges, culverts, and levee systems. The program comes with the 
Corps' Data Storage System software and GSS device drivers. UNET is written 
for DOS systems and comes with complete, bound copies of the User's Manual. 
(http://www.waterengr.com/) 

Watershed Modeling 

Watershed Modeling is a comprehensive drainage program that determines runoff 
using industry-standard techniques. The program models flood control structures 
such as detention basins with various outlet structures. Hydrographs can be 
created or imported from an ASCII file. Actual or synthetic rainfall distributions 
can be used. Hydrographs can be imported or combined at any point. The 
program can be used with Auto CAD, MicroStation, or as a stand-alone program. 
(http://www.eaglepoint.com/HH/HH.htm) 

Water Surface Profiling 

The Water Surface Profiling program uses HEC-2 and WSPRO methodology to 
compute flows or channels, bridges, culverts, etc. This model produces a 
comprehensive hydraulic analysis. It can produce plan, profile, and cross-section 
analyses. 

(http://www.eaglepoint.com/HH/HH.htm) 
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Appendix D 

Comparison of GEOPAK and Storm Works 
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INTRODUCTION 

Numerous software packages are available for the design of storm drainage systems. These 

packages eliminate the tedium of having to design an entire network element wise. This is 

accomplished by designing a network from a single module. The power of engineering analysis 

along with interactive graphics helps reduce design and production time and increase quality 

control several notches. Keeping this end in mind, this study evaluated two such software packages: 

GEOP AK Drain and Storm Works. In preparing this report emphasis was placed on what is there to 

be done rather than how it is to be done. In other words the discussion details the features offered 

by each software package rather than the usage. In order to compare the software, knowledge about 

the constituent elements is a pre-requisite. Hence this Appendix is organized into sections that go 

into the salient features of GEOP AK Drain and Storm Works. 
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Chapter 1 

FEATURES OF GEOPAK DRAINAGE 

PROJECT MENU 

The Project Menu selections are utilized for creating new GEOPAK Drainage projects, 

opening existing projects, saving projects, establishing the project preferences and editing 

the Drainage Library. GEOPAK Drainage does not possess an auto save feature. 

Therefore, the Project> Save option must be regularly exercised. 

PREFERENCES COMMAND 

This option is invoked to support user-defined preferences that can be used to set project 

specific options. A dialog box offers preferences for various options. Below is a brief 

discussion of these options: 

eJ Preferences - Units , 

Options 

Units 
Project Components 
Hydrologic: Method 
Rainfall Parameters 
Land Use Options 
Frequency Options 
Intensity Option 
Junction Losses 
Inlet Options 
Node Options 
Link Options 
Design Symbology 

0 K =J l,!;ancel ( 

(!) English 

Drainage Area = Acres 
Length= Feet 
Dimension= Feet 
Depth= Feet 
Discharge= Cubic Feet per Second 
Velocity= Feet per Second 
Intensity= Inches per Hour 
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0 Metric 

Drainage Area= Hectares 
Length= Meters 
Dimension= Meters 
Depth= Meters 
Discharge= Cubic Meters per Second 
Velocity= Meters per Second 
Intensity= Millimeters per Hour 



Units: A choice of English or Metric units can be made. 

Project Components: Directories and files for Drainage Library, GPK file and Drainage 

Cell Library can be manipulated using this dialogue box. 

Rainfall Parameters: Rainfall data source can be chosen. 

Land Use Options: Drainage Library File is displayed and Land Use Data Source can be 

chosen. 

Frequency Options: Computation frequencies and runoff coefficient peaking factors can 

be chosen. 

Intensity Option: Minimum Time of Concentration and Intensity Options can be chosen. 

Junction Losses: Establishes the default junction loss equations and coefficients utilized in 

pipe hydraulic calculations for the current project. Loss coefficients can be assigned to the 

following junctions: 

Pressure expansion 

Free surface expansion 

Pressure contraction 

Free surface contraction 

Bend Loss computation 

Terminal inlet/junction 

Simple junction 

Complex junction 

Inlet Options: Inlet Bypass Options, Link Bypass Flow Options and Default Spread N 

values can be defined. 

Node Options: Default Node ID Prefix and Automatic Link Updating option can be defined. 
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Link Options: The following items can be defined: 

• Default Link ID Prefix 

• Design optimization options: (a) minimize depth of cover; or (b) minimize pipe size 

• Link Design Options: (a) design for full capacity; or (b) design partial capacity with [d/D] 

ratio input; or (c) design partial capacity with [q/Q] ratio input 

• Hydraulic gradeline options: (a) equal hydraulic gradeline; or (b) equal energy 

gradeline. 

Design Symbo/ogy: Element parameters for drawing both plan and profile views of 

drainage system are defined. 

DRAINAGE LIBRARY 

The Drainage ILbrary stores data and standards, which can be shared by different 

designers. There are 4 major categories in the Library: 

• Rainfall Data 

• Land Use Runoff Coefficients 

• Nodes; i.e., inlets, outlets, junctions, etc. 

• Links; i.e., pipes 

Various File operations are provided in the Drainage Library. These allow one to create a 

new library, open an existing library file or save a file. For each of the above 4 categories, 

the user can add, delete or modify items associated with a particular category. Items 

included in each category are: 

Rainfall Items: GEOPAK Drainage stores rainfall data either in the form of Intensity 

Duration Frequency (IDF) tables or as an equation. There are three different preset 
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intensity duration equation formats. For such rainfall equations, user-defined frequency 

variables can be input. 

Land Use Items: These items are used to store runoff coefficients and graphic symbology 

for various land uses contained in drainage products. The parameters input are Item ID, 

which is used to recall the item from within a GEO PAK Drainage project, description of the 

land use item, description of each land use, runoff coefficients and level, color, style and 

weight of the graphic elements. 

Node Items: Node library items contain descriptions, plan view representation and 

dimension information for node structures. The node types are curb, grate, slotted drain, 

junction, outlet and other generic nodes such as grade breaks. Further specifications for 

each node can be made, such as profile types, dimensions, etc. 

Link Items: Link items are used to store the pipe configurations. Three types of properties 

are specified for each pipe: 

(a) Shape: arch, box, circular, ellipse or pipe arch. 

(b) Material: aluminum or steel. 

(c) Type: standard, low profile or high profile. 

When a pipe item is added or modified, a dialog box appears that prompts for the item ID, 

description, shape, material, Manning's roughness coefficient, rise and span. 

COMPONENT MENU COMMANDS 

The component menu selections allow one to add, edit and delete the various elements 

that comprise a drainage system, which include Areas, Nodes, Links, Reaches, and Land 
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Uses. Each of these tools invokes a dialog wherein the specific component information 

can be added or edited. 

DRAINAGE AREA ELEMENT 

Drainage Areas are used to compute peak discharges or to attach computed discharge 

values to nodes within a project. The Drainage Area boundaries can be delineated using a 

Digital Terrain Model (DTM} drawn using MicroStation, or keyed in as a total area value. 

Using the commands in the component menu, drainage areas can be added, deleted, and 

edited. This dialog can also be invoked using the Navigator Tool. The Drainage Area 

Definition dialog box appears when areas are to be added, updated or deleted. The figure 

below shows the dialog box. 

s'DrainageArea Definition ..----~ ~---~■ 
Drainage Area ID I CB A- 8 1 UD Node] LAdd Node j 

Description 
'i======' 

Area Definition -------------~ 

Drainage Area I 0.000 

Base C Value I 0.000 . 

Time of Concentration I 0.000 
Computations 

Area CValue 

Total Subareas : 0. 000 

Remainder: 0.000 

Composite: 0.000 

Computed Intensity: 0.000 

Computed Discharge: 0.000 

0.000 

0.000 

0.000 

J 

Delineate 
Subareas 

·compute 
Discharge 

The dialog fields in the Drainage Area Dialog box with brief descriptions are: 

Drainage Area ID: Drainage Area Identification 

ID node: Enables the designer to select a previously defined node. 

Add/Edit node: Enables the node configuration dialog box. 
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Description: This input is optional. 

Drainage Area: This parameter is either input or is computed when a shape is selected. 

Select Shape: Select a previously drawn shape. 

Create Shape dialog: Create a new shape. 

Create DTM shape: Create a Drainage Area shape using the Delineate Watershed­

Drainage Area tool. 

Base C value: The runoff coefficient for the drainage area. 

Time of Concentration: Tc expressed in minutes. 

When these values are input the following computations are performed: 

Total Subareas and C value 

Remainder Area and Remainder C value 

Composite Area and C value 

Computed Intensity 

Computed Discharge 

GEOPAK Drainage allows one the flexibility to delineate Subareas. Subareas are 

smaller components within a drainage basin that exhibit different land coefficients or 

roughness coefficients. The fields input in this dialog box are the area of the Subarea, 

runoff coefficient and description. When the Automatic Delineation option is exercised, 

GEOPAK Drainage automatically delineates the subareas, drawing its values from the 

Land Use Table of the Drainage Library. 
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'ii; S ubarea Definition Tool 13 
To Node ID: CB A-8 

S b - u areas 
Subarea Runoff C Description 

0.000 0.000 [:] 
1.888 0.500 

□ ·. 

0 
I 1.000 I o.5oo I 

I Automatic Delineation I Apply 
- 1 

] 

THE NODE ELEMENT 

Nodes in GEOPAK Drainage are the key points within a drainage network. Nodes create 

the inlets, junctions and outlets in the network and provide for connectivity of the link 

system. Links can change size or slope only at nodes. Six categories of nodes may be 

placed in a drainage project, including: 

• Curb: used for curb opening inlets with or without pipe confluences. 

• Grate: used for grate opening inlets with or without pipe confluences. 

• Slotted Drain: used for slotted drain inlets with or without pipe confluences. 

• Junction: used for any confluence of pipes, structure location (that is not an inlet), pipe 

size or slope change, or flow addition that does not require an inlet. 

• Outlet: used for the outlet, or outfall, of a storm drain network. 

Using the Node pull-down menu, nodes can be added, edited or deleted. Selecting any of 

these options activates the Node Configuration Dialog box. 
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l; Node Configuration - Properties ~--~ 13 
Options Node ID I CB A '. 8 

Description 

I ID Area] I.Add Area I 
Properties 
Location 
Spread Criteria 
Elevations 
Junction Loss 
Discharge Options 
Computations 

Add 

Node Type _Cu_rb ___ ........ l Profile On Grade ..-j 
Library Item: I Select I 

Library Parameters ------~~~~--. 

Length: 0.000 
Depression Width: 0.000 
Depression Depth: 0.000 

r D epres:sion 
r t Slope 0.000 

By Pass to Node . O[] Ma:,: By Pass I 0.000 

Various parameters can be specified for a variety of options that include: 

Properties: Defines the type of node, library reference for the node and if applicable, 

bypass flow properties. 

Location: Defines the location and reference information for the Node. 

Spread Criteria: Applicable to inlets only, this option is used to define the spread criteria 

for ponded width and depth calculations used in the inlet hydraulic computations. 

Elevations: Defines the Node elevation, critical elevation, and criteria for the elevations of 

Links connecting to the Node. 

Junction Loss: Defines, overrides, or disables Junction Loss computations for the Node. 

Discharge Options: Defines the Node discharge options and source of the discharge for 

the Node. 

Computations: Applicable to inlets only, this option evaluates the hydraulic adequacy of 

the Inlet and displays the current hydraulic computations for the inlet. 
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THE LINK ELEMENT 

Links connect and convey runoff from various nodes within a network to the outlet and 

consist of pipes, boxes or ditches. Links can be added, modified and deleted using the 

Link configuration definition dialog box. 

'ii; Link Configuration Definition 13 
Options -Conditions 
Constraints 
Computation 

Type 

(!,1 Pipe 

0 Ditch 

. · L_ Add 

Link ID I SS - 12 

Description 

From Node ,-.---- O[] To Node I . O[] 
Length: 0.0000 I ID MS Element] Lundo MS ElementJ 

Configuration 
Shape Arch ..,I Material Aluminum ..,I Type Standard 

r Design Size Size: I Select I 
r Design Barrels Number of Barrels y I 

Manning's n I 0.000 ... · . 

Various sets of parameters can be chosen for four items as follows: 

Definition: Defines the Link's path, connectivity, shape, material, roughness coefficient, 

size, and design options. 

Conditions: Defines or reviews the elevation condition for the Link, including minimum 

depth, soffit, invert, and slope data. It also includes the profiling options for holding certain 

values constant. 

Constraints: Defines the Link constraints, including the minimum and maximum rise (size), 

slope, and velocity used in Link design. 

Computation: Reviews the Link hydraulic computations. 
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THE REACHES ELEMENT 

A Reach is a path between two nodes, spanning one or more links. Reaches allow users 

to define a path running in either upstream or downstream direction in a drainage network 

and visualize profiles (ground, pipes, depth of cover, etc.) along that path. The 

identification of the From Node and To Node is required to define a Reach. GEOPAK 

Drainage automatically traverses the Network and finds the Links connecting the two 

Nodes. A Reach is only needed for the purpose of profile visualization and is not required 

to complete the drainage design process. Using the menu options provided, Reaches can 

be added, edited or deleted. 

~Reach Configuration E3 
Reach ID I I Description 

From Node [iliJ To Node .-1 ---[ili] 
Profile Registration-----------, 

Reference TIN I Files I 
Station ! 0.0000 . X ...,, o"'""'.o"""oo'"""o-_ --._. E]p 

Elevation I 0.0000. Y I 0.0000 ~-- . 

I Scale 
I Horizontal I 0.0000 Vertical I 0.0000 

ID Reach Element 

Draw Add 

THE LAND USES ELEMENT 

GEOPAK Drainage graphically defines areas or regions of different land uses and 

subsequent runoff characteristics in order to automatically track and compute runoff 
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coefficients for Drainage Areas. These land uses are defined using MicroStation shapes, 

specific symbology, and related runoff coefficient parameters. 

When Component > Land Use is selected, a dialog box appears that consists of the 

following elements : 

'§ Land Use Boundary Tools El 
Runoff C Land Use Description 
: 0.50d ... ·Grass ......................... : .!-
b.'650 .... Commerciai ..................... . -0.930 Pavement 
0.980 Buildings >--; 

,:!J 

Create Shape I I Select Sh,:pe I 

Runoff/ Land Use Description List Box: This box depicts the Land Use Descriptions and 

corresponding runoff coefficient values for entries in the currently selected Land Use Item 

within the Drainage Library. 

Create Shape Button: This button is used to define a new Land Use Area. 

Select Shape Button: This button is used if the Land use area has been previously defined 

as a MicroStation closed element. 

NETWORKS MENU 

A GEOPAK Drainage Network is defined as a series of interconnected Nodes and Links 

draining to a single outlet. Multiple Networks can be maintained in a single project. The 

final process in the design and analysis of a storm drain system are the network 

computations. Hydraulic computations on pipes and ditches require a network to be 

defined and successfully built. There are six options supported by the network pull-down 

menu: 
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Add: Used to define the network and associated data. 

Edit: Utilized to edit a previously defined network. 

Delete: Utilized to delete a network and associated data. 

Design: Enabled only when the active network is defined. Computes the active network 

system hydraulics and displays the number of nodes and links. 

Analyze: Enabled when an active network is defined. Is a shortcut to the Analyze 

Procedure without having to invoke the Network dialog. 

Active Network: Used as a shortcut and organization tool to limit the information viewed 

only to the active network. 

When the add, edit and delete options are exercised, the network configuration dialog box 

appears whose features include: 

Input Parameters 

~ Network Configuration El 
Network ID II 

~;;:;::;:;;:;;;;;:;::;:;;:;;;=!---
Description 

Outlet Node -1 __ .;..__ OQJ 

-Validation --~ -Computations -

I Build Network I I ,P~sign I 
I Highlight Network I I Analyze I 

Network ID: Identification of the network. 

Description: Description of the network. 

Outlet Node: Identification of the outlet node. 

ID: This button is used to dynamically identify the outlet node. 
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Validation Group Box 

Build Network: This button builds the storm drain network starting from the outlet node. 

The purpose of building a network is to determine whether the storm drain system is ready 

to be analyzed or designed. 

Highlight Network: This button highlights all elements, Areas, Nodes and Links contained 

in the active network to aid visual inspection. 

Computations Group Box 

Design: Performs the hydraulic design of all the components contained in the network and 

evaluates it. 

REPORTS MENU 

GEOPAK Drainage provides a set of commands to generate either custom or standard 

reports. The reports pull-down menu offers several report options. Of these, Drainage 

Areas, Inlets, and Storm Drains/Links are standardized reports, while the Builder and 

Generate menu selections are utilized for customized reports. Standardized reports are 

designed for viewing only, whereas hard copy output can be produced from customized 

reports. 

A few features are common to all standardized reports. These features in brief are: 

• Selecting a Network, either the Active Network or All Networks. 

• An Edit option that brings up the Drainage Definition Dialog box. 

• A Highlight option that is used to highlight a specific item. 

• A Window Center option that centers the specific area selected. 

The following screen shots show the reports along with the features afforded by them. 

D-15 



Reports > Drainage Areas 

~Drainage Area Summary Ei 

Identification Runoff C Drainage Area Time of Cone. Time Used Intensity Discharge 

CBA-1 0.450 0.398 5.00 10.000 4.076 0.731 
CBA-2 0.769 0.417 5.00 10.000 4.076 1.306 
CBA-3 0.450 1.024 5.00 10.000 4.076 1.879 
CBA-4 0.702 8.196 5.00 10.000 4.076 23.456 
CBA-5 0.782 1.828 5.00 10.000 4.076 5.824 
CBA-6 0.928 0.351 5.00 10.000 4.076 1.329 
CBA- 7 0.450 2.779 5.00 10.000 4.076 5.098 

Network All Networks ..-1 0 r Highlight r Window Center 

Reports> Inlets> On Grade/On Sag Inlets 

~On Grade Inlet Computation Summary 13 
Ponded 

I.D. Type Discharge Width Depth Slope Length Width Depr. Capacity By Pass To Node 

CBA-1 Curb 1.210 8.016 0.160 0.740 10.000 n/a 0.250 1.210 
CBA-2 Curb 1.282 6.454 0.134 2.305 10.000 n/a 0.250 1.282 CBA-3 
CBA-3 Curb 1.844 7.395 0.154 2.305 10.000 n/a 0.250 1.844 
CBA-5 Curb 5.715 11.297 0.235 2.305 10.000 n/a 0.250 4.256 1.459 Unassigned 
CBA-6 Curb 1.305 6.498 0.135 2.305 10.000 n/a 0.250 1.305 
CBA-7 Curb 5.003 10.906 0.227 2.132 10.000 n/a 0.250 3.973 1.030 Unassigned 

. 

Network All Networks ... , 0 r · Highlight r Window Center 

Reports > Storm Drains / Links > Link Configuration 

~Storm Drain Configuration Summary for Network SYSTEM A - Calculations CuJJent 13 

I.D. 

ss -10 
ss -11 
ss -8 
ss -9 
ss -6 
ss · 7 
SS-4 
ss -5 
ss · 1 
ss -3 

Upstream 
I.D. 

MH 4 
CBA· 7 
MH 3 
CBA-6 
MH 2 
CBA-5 
MH1 
CBA-3 
CBA-2 
CBA-1 

Downstream 
I.D. Discharge Length Shape # 

OUTLET A 35.005 132.11 Circul 1 
OUTLET A 5.098 163. 00 Circul 1 
MH 4 33.675 150. 00 Circul 1 
MH 4 1.329 19. 486 Circul 1 
MH 3 27.851 200. 00 Circul 1 
MH 3 5.824 52.826 Circul 1 
MH 2 25.973 120.00 Circul 1 
MH 2 1.879 45. 560 Circul 1 
MH1 1.306 170. 95 Circul 1 
MH 1 24.666 30. 251 Circul 1 

0 r Highlight r Window Center 
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Upstream Downstream 
Rise Span n Slope Invert Invert 

2.500 n/a 0.012 4.891 858.576 852.115 +: 
1-\ 

1.500 n/a 0.012 2.024 856.415 853.115 
2.500 n/a 0.012 2.453 862.256 858.576 
1.500 n/a 0.012 0.400 859.654 859.576 
2.500 n/a 0.012 1.569 865.394 862.256 
1.500 n/a 0.012 1.169 863.874 863.256 
2.500 n/a 0.012 3.097 869.111 865.394 
1.500 n/a 0.012 0.400 866.577 866.394 
1.500 n/a 0.012 2.377 874.176 870.111 -· 
2.500 n/a 0.012 0.400 869.232 869.111 >-
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Reports > Storm Drains / Links > Link Hydraulic Computations 

~Storm Drain Configuration Summary for Network SYSTEM A - Calculations Current 13 

I.D. 

55-10 
55 · 11 
55 · 8 
55-9 
55-6 
55.7 
55.4 
ss -5 
ss · 1 
ss -3 

Upstream 
I.D. 

MH 4 
CBA· 7 
MH 3 
CBA-6 
MH 2 
CBA-5 
MH1 
CBA-3 
CBA-2 
CB A-1 

Downstream Upstream Downstream Uniform Actual 
I.D. HGL HGL Discharge Capacity Slope Loss VelocityDepth Yelocit_yDepth 

OUTLET A 860.586 853.194 35.005 105.712 5.595 0.000 18.432 1.027 17.248 1.080 
OUTLET A 857.284 853.684 5.098 17.417 2.209 0.000 8.234 0.572 8.285 0.569 
MH 4 864.230 859.840 33.675 74.866 2.926 0.000 14.030 1.228 13. 530 1. 264 
MH 4 860.584 860.586 1.329 7.742 -0.011 0.000 3.076 0.440 1.051 1.010 
MH 3 867.194 863.516 27.851 59.873 1.839 0.000 11.386 1.247 11.237 1.260 
MH 3 864.806 863.988 5.824 13.237 1.548 0.000 6.871 0.726 6.803 0.732 
MH 2 870.848 866.422 25.973 84.122 3.689 0.000 14.356 0.990 13. 666 1. 027 
MH 2 867.196 867.194 1.879 7.742 0.005 0.000 3.382 0.528 1.961 0.800 
MH1 874.603 870.386 1.306 18.875 2.467 0.000 5.882 0.275 5.882 0.275 
MH1 870.992 870.848 24.666 30.231 0.475 0.000 6.679 1.760 6.775 1.737 

0 r Highlight r Window Center 

_!. 

·-·-
♦ 

The Report Builder tool is used to build reports on drainage component features such as 

Area, Inlet, Node and Link. A particular report format can then be saved for subsequent 

reuse. The Report Builder dialog box is depicted below. 

i::Report Builder - Untitled 13 
Report File 

Component Report Basis Area ..-, r Include Active Network Only 

Component Data Area ..-1 
Available Data Report Data .---------r-Area-ID +1 

_1 

Area - Description 
Area - Time of Concentratior Include> I Area - Tc Used 
Area - Discharge 

<Exclude .... J Area - Intensity 
Area - Base C Value 
Area - Composite C Value Move Up 

Area - Composite Area 
Area • Total S ubarea C Valu Move D,.!IYm.J 
Area - Total S ubarea i-

Area - Remainder C Value ,-I 
♦J 

Output 

Default Output File Name I untitled.lis Files J Generate 

Default Output File Extension n;;--- Decimal Places~ 

r Include Field Names Delimiter Comma ..-1 
View I 
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The Report > Generate command can be used to access a custom format saved within 

the Report Builder. Additional reports can then be generated using the same layout. 

't!;Generate Report fJ 

Drainage Report Format File "-"l(l=mm..........;;.r:Ti"""■ -----"--"I I Files I 
Output File Name I untitled.lis I Files I 

View J 

TOOLS MENU 

NAVIGATOR MENU 

The Navigator tool provides a means to identify, add, edit, delete, and query the 

components of the current project. The Navigator also provides graphical maneuvering 

tools to move through the design file and view the components with highlighting and 

window centering functions. When the navigator tool is accessed, a dialog box appears, 

with the following features: 

~Navigator 13 
View Tools 

Network All Networks .,.. , 

: ¢~~P9t)~~.i: Area T I 
ID Description 

~ [:] D [2J r Query 

r Highlight r Window Center 



Network: Either all the networks are selected or only the active network is selected. 

Component: A list box allows one to choose the various components supported by 

GEOPAK Drainage. 

ID/Description List Box: Lists all defined elements of the specified component and their 

respective descriptions. 

Add/Delete/Edit Buttons: These buttons are used to add, delete or modify elements of a 

specified type and ID. 

Query: This check box activates the query tool that searches for components either by a 

value or a constraint. 

The View > Global Editor option in the Navigator tool brings up the global editor dialog 

box. The Global Editor is used to edit the input variables and parameters of the system 

under consideration. Numeric variables are edited with the New Value field, and 

alphanumeric variables use the overwriting text or find and replace text fields. 

~Global Editor 13 
View Tools 

:~~~0~;~: All Networks ..., I 
Component Area ..., I 
ID Description 

IJBGJD[Z] rQuery 

r Highlight r Window Center 

Current Value: Not Available 

Variable to Edit 

Area·ID 
Area · Description 
Area - Time of Concentration 
Area - Composite Area 
Area - Remainder CValue 

lw!PPI?. Edit With Confirm I 
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When the Tools> Update Graphics is selected in Navigator or Global Editor, the graphic 

representation of the selected components will be updated. 

DRAINAGE TOOLS 

Exercise of this option brings up a tools palette that allows one to analyze and evaluate 

drainage patterns. The tools that can be employed are: 

~ 
CREATE REFINED WATERSHED: This tool is used to refine a Triangulated Irregular 

Network (TIN) file for use with other Drainage tools. This tool processes the entire 

network, evaluating ridges, sumps and low points, and determines more precise flow 

boundaries within the triangles. Selection of this icon invokes a dialog box that prompts for 

the original TIN file name and the watershed TIN File name which is the refined file to be 

created. 

'(@ 
DELINEATE TIN WATERSHEDS: The Delineate TIN Watershed tool displays the 

watershed boundaries that exist within a Digital Terrain Model. A watershed is defined by 

either a low point within the TIN or a low edge point along the TIN hull. MicroStation 

shapes may be created for each watershed contained in the TIN. 

Q 
DELINEATE WATERSHED: This tool further delineates watersheds at any location within 

the network. A boundary element representing the pour point of the watershed is 

indicated, and the contributing watershed area is computed and delineated. This tool also 

requires that the overall watershed boundary containing the pour point be selected. This 
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facilitates subdividing watersheds. The resulting watersheds can then remove previously 

defined upstream watersheds to depict conditions as would occur if structures upstream 

are intercepting portions of the contributing watershed. 

~ 

MAXIMUM DESCENT PATH FROM TRIANGLES: This tool evaluates the flow paths 

contained in the network. This tool performs a downstream trace from the centroid of each 

triangle contained in the region specified. The results help provide visualization of the flow 

patterns within the TIN. 

fe!I 
DELINEATE SUMP LINES: A sump line is a triangular edge where the flow on each side 

of the edge is towards the edge, e.g., as in streams and ditches. This tool indicates the 

sump lines within a region of the network. 

·~ 

DELINEATE RIDGE LINES: A ridge line is defined as a triangular edge where the flow on 

each side of the edge is away from the edge. This tool indicates the ridge lines within a 

region of the network. 

fpV 
DELINEATE LOW POINTS: The Delineate Low Points Tool locates all the low points 

within a region of a TIN. 

~ 
DELINEATE HIGH POINTS: The Delineate High Points Tool locates all the high points 

within a region of a TIN. 
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[)~I 
DOWNSTREAM TRACE: The Downstream Trace Tool delineates the flow path 

downstream from a given point in the TIN. The indicated path follows the steepest 

descent from the point through the TIN ,terminating at a low point or the edge of the TIN. 

~ 
UPSTREAM TRACE: The Upstream Trace Tool delineates the flow path upstream from a 

given point in the TIN. The indicated path follows the steepest ascent from the point 

through the TIN, terminating at a high point or the edge of the TIN. 

0 
DELINEATE FLOW DIRECTION: The Delineate Flow Directions Tool indicates the 

direction of flow within the triangles for a given region of the TIN. 
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Chapter 2: 

FEATURES OF STORMWORKS 

FILE MENU 

The File > Open Project command loads all the information associated with an existing 

project. 

The File > Save As command creates a new project and specifies which data files to 

store there. A project is comprised of surfaces, coordinate geometry projects, a general 

preference file, and a geometry annotation preference file. 

SURFACE COMMANDS 

The File > Surface commands create, open, and save surface files. Surface files can 

contain triangle and point information that define a Digital Terrain Model (DTM). A DTM is 

a numerical representation of a ground surface that is made up of x, y, z coordinates. 

The File > Surface > New command creates a new, independent surface, which becomes 

the active surface. The active surface is the surface that receives the input. When this 

command is used, the software creates a slot in memory where surface data is stored. 

After this slot in memory is created, point data can be loaded into the surface. There is no 
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limit to the number of points or triangles that may be loaded into individual surfaces. An 

unlimited number of independent terrain models can be used simultaneously. 

The File > Surface > Open command is the primary means of importing existing point 

and triangle information into a surface. This command can be used after previously 

creating a surface, loading terrain model data, and then saving the surface. 

The File > Surface > Save command saves point and triangle information from the active 

surface to a digital terrain model (DTM} or topological triangulated network (TTN} file. 

Note that this command does not prompt before overwriting an existing surface. 

The File > Surface > Save As command saves point and triangle information from an 

existing surface to a digital terrain model (DTM) or topological triangulated network (TTN) 

file. 

The Geometry command on the File pull-down menu allows one to create, load, and save 

geometry project files. These files contain geometric information defining points, 

alignments, super elevation lists, and their parameters. A geometry project is similar to a 

database in that it stores and organizes information about several geometry projects at a 

time. Note that only one geometry project can receive input at a given time. 

The File > Geometry > New Geometry command allocates memory for a new geometry 

project. A geometry project needs to be created before working on the design. 
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It is worthwhile to note here that Geometry project files are interchangeable between 

StormWorks, lnRoads, lnRail, and all subset products such as lnXpress, CogoWorks, 

SiteWorks, and TrackWorks. 

The File > Geometry > Open command loads an existing geometry project file into 

memory. 

IMPORT COMMANDS 

StormWorks provides various commands to import data. These commands are used to: 

(a) Transform MicroStation graphic elements into geometry data 

The File > Import > Geometry From Graphics command transforms MicroStation 

graphic elements into geometry data. 

(b) Load ASCII files that contains alignment data 

The File > Import > ASCII Geometry command loads a horizontal or vertical 

alignment or COGO points by loading an ASCII file that contains the alignment 

information. One can load horizontal alignments containing any combination of the 

following elements: tangents, circular curves, and spiral curves. Note that this 

command does not support station equations, vertical clothoids or non-linear spirals. 

(c) Load ASCII surface data 

The File > Import > ASCII Surface command loads digital terrain model data stored in 

an ASCII text file into a surface. Importing ASCII data allows one to define the 

coordinates of points of a surface using data collected in the field. 
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(d) Load digitized model and MicroDrainage data. 

The File > Import > Surface From Graphics command loads terrain model data 

digitized in a MicroStation design file into an existing surface. Terrain model data can 

include digitized contours and graphic elements representing the location of random, 

breakline, contour, interior boundary, or exterior boundary points. One can select 

elements from a reference file as input to this command. 

The File> Import> ASCII Model command reads existing ASCII data files to create a 

drainage network. This file contains the minimum amount of data necessary to load 

the network and to design or model it. 

The File > Import > MicroDrainage.SWS command loads an existing MicroDrainage 

network file. These files contain network structures based on calculations performed in 

the MicroDrainage product. 

PREFERENCE COMMANDS 

For any given command, multiple sets of parameter configurations can be saved to a 

preference file. The individual sets of saved parameters, known as preference sets, can 

be recalled from the preference file. This provides for reuse wherein different drainage 

projects can make use of the same set of preference files. 

The File > Open Preference > General command opens a preference file, allowing one 

to gain access to a different set of general parameters. General preference files define 
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preferences for everything except coordinate geometry elements (alignments and 

geometry points) and horizontal element annotation. 

The File > Open Preference > Geometry Annotation command opens a different 

preference file, allowing one to access a different set of geometry parameters. Geometry 

preference files define preferences for coordinate geometry elements only. 

Using the File > Save As > General command saves a different preference file to gain 

access to a different set of parameters at another time. Many commands contain 

numerous parameters governing its processing. These parameters can be stored in a file 

known as a preference file. 

The File > Save As > Geometry Annotation command saves a user-defined preference 

file, facilitating recall of a set of geometry parameters. 

PARAMETER COMMAND 

The parameter file commands located on the File pull-down menu allow one to open and 

save default parameters for placing StormWorks structures. 

The File > Active Parameters > Open command loads previously saved design project 

parameters and default criteria into the active design from a specified ASCII file. 
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The File > Active Parameters > Save command saves the active StormWorks 

parameters into an ASCII parameter file. These stored parameters are then recovered 

automatically when the File > Active Parameters > Open command is chosen. 

The File > Active Parameters > Save As command saves an existing parameter file to a 

different name or a different directory. When the file is saved, it is stored on the hard-disk 

drive, and can be opened at any point during a design session. 

STYLE COMMANDS 

The Style commands help in annotating profiles and the network data. They are used to 

set up line styles, font types, colors, and text sizes. 

The File > Style > Open command opens a file that defines the appearance of 

StormWorks elements. The level, color, line style, and line weight of graphics of 

StormWorks elements such as pipes and nodes can be defined. The File> Style> Save 

command saves the current style file. 

ANNOTATION SETTINGS COMMANDS 

The Annotation Settings commands located on the File pull-down menu allow one to 

define annotation parameters. These files are used to set up annotation parameters, such 

as font, text size, color, weight, and label placement, when annotating both networks and 

profiles. 
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QUIT COMMAND 

To exit StormWorks and keep MicroStation active, the File> Quit command is used. When 

this command is chosen, a check is made to verify that the project data has been saved. 

The user is prompted to save the project in case this command is executed after changes 

are made to the project. 

SETTINGS MENU 

The Settings commands provide a framework for all other StormWorks commands. The 

Settings command can be used in the following ways: 

• The write lock can be turned on and off. 

• Preferences can be set for units and formats. 

• Parameters can be set for placing and displaying drainage structures in designs. 

• Parameters for computing area drainage and runoff can be set. 

• Parameters for annotating structures and profiles, select flow and time to inlet 

equations for calculations can be set. 

• Parameters for MicroDrainage calculations can be set. 

LOCKS COMMANDS 

The Settings > Locks command allows access to the Write, Snap, Station, Report, and 

Dialog locks. 

The Settings > Locks > Dialog command opens a dialog box that facilitates review and 

change of locks quickly and dynamically. 
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PREFERENCES COMMAND 

The Settings > Preferences command opens the Preferences dialog box. The 

Preference dialog box is used to define preferences for precision, format, and units. A set 

of default preferences for these parameters is displayed on the dialog box. 

~ Preferences 13 
Preferences 

Easting/Northing: _0.1_2 _ _. 
Elevation: 0.12 ___ ...., 

Linear: 0.12 ___ __, 

Slope: _0.1_2 _ __. 

Station: 0.12 ----
Area Units: 0.12 ___ __, 

Cubic Units: 0.1 ----
Station Format: ss+ss.sss 

Slope Format: _50_% ___ _, 

'.Li~~a~ Unit;:: Metric ........ ______ __, 

I Cancel I 

PIPES COMMAND 

The Settings > Pipes command opens the Pipe Parameters dialog box, which lets one 

set parameters that control the layout and design characteristics of a pipe. These 

parameters are used when placing pipes in the design. Similar commands are used for 

the layout and design of inlets, manholes, channels, culverts, and pumps. 

;;)Pipe Parameters 13 

:Material:: Concrete 

R o~~h~~~;: I 0. 01 3 

Shape: Circular 

Width: I 24.00. 1n 
Height l...-2-4-0□---- 1n 
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AREAS COMMAND Palettes 

The Settings > Areas command opens the Area Parameters dialog box, which is used to 

set parameters required for computing drainage area and peak runoff (flow rate). The 

computation method is selected among the Modified Rational method or SGS unit 

hydrograph method, and the required parameters are entered, which vary depending on 

the method. The Flow > (Compute Flow) command can then be used to compute the 

area and runoff of a selected shape (polygon). 

m;)Area Parameters 13 

:c~~pu·t~tio~-M~th~d:: Modified Rational ................ 

Rainfall lntensit_y I 4,280000 

Runoff Coefficient I 0.30 

r Use Time of Concentration 

OK 
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ANNOTATION COMMAND 

The Settings > Annotation command opens the Annotation Styles dialog box, which is 

used to define parameter values for textual labels for structural design elements, such as 

pipes, manholes, inlets, channels, and so on. A label can be assigned to each attribute of 

a given element type (structure). Once the element type and attribute are selected text 

symbology, positioning parameters and the label name prefix and suffix values can be 

defined. Text symbology includes items such as color, font, height, etc. Positioning 

parameters are position, offset, spacing and angle. The parameter values can be saved to 

an annotation (.ann) file that can be opened later to retrieve a particular set of values. 

■Annotation Styles 13 
file fu,mbology 

Element T_ype 
: . 
· · Pipes 

Attribute 

cc Pnt Flw 
Angle 
Area Runoff 
B_ypass From 
Capacit_y 

Position: · Center: I 
0 ffset: I 0. 000000 

Spacing: I 0.000000 

Angle: I 0. 000000 

Precision: · 0.12 ====:,__­Prefix: 

Suffix: 
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PROFILE ANNO TAT/ON COMMAND 

The Settings > Profile Annotation command opens the Profile Annotation Styles dialog 

box, which is employed to define parameter values for textual labels for profile structures 

and junctions. Attributes can be assigned similar to the annotation command. 

If.I Profile Annotation Styles f3 
f_ile _fulmbologv 

: . Element Type 

Profile Structures 

Attribute 

cc Pnt Flw 
Angle 
ApprchVel 
Area Runoff 
Bypass From 

STRUCTURE IDs COMMAND 

+ 

• 

Position: Center: I 
Offset: I 0.000000 

Spacing: I 0. 000000 

Angle: I 0.000000 

Precision: 0.12 ;.:====--­
Prefix: 

Suffix: 

The Settings> Structure IDs command opens the Structure IDs dialog box. 

6 Structure IDs f3 

Prefix Counter 
Pipe: p I 2s 

Channel: I CHI ps 

Culvert: I DI j23 

Manhole: I MH I 24 . 
Inlet: j IN. I 25 

Pump: jPM 123 

Area: A I 22 . 

OK I 1-i:;,~:cel] 



The Dialog box is utilized to review and define identification names (IDs) for each 

structure. The default structure IDs consist of a one or two character prefix that describes 

the structure type, followed by a counter number that is automatically assigned (in 

sequential order) to each structure as it is placed in the design. The IDs can also be 

customized to meet the user's needs. 

FLOW EQUATIONS COMMAND 

The Settings > Flow Equations command activates the Flow Equations dialog box, 

prompting the user to select the equation to use for computing discharge flow rate. The 

equations that can be selected are either the Manning or Darcy/Colebrook equations. 

~ Flow Equations £j 

/.1~~ ~9~~ti_o~1.: _M_a_nn_in ... g __ _ 

Kinematic Viscosity: I O 00000113. Sqft/s 

I OK I I Cancel j 

TIME EQUATIONS COMMAND 

The Settings > Time Equations command opens the Time of Concentration Equations 

dialog box, prompting the user to select the equation to use for computing the time of flow 

to an inlet. Two equations are provided: the FAA flow time equation or the Kirpich flow 

time equation. These equations are used in conjunction with the Palettes > Flow > (Inlet 
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Time) command. Note that the runoff coefficient of the drainage area must be computed 

using the Settings> Areas command, prior to using the time equations. 

~ Time of Concentration Equations 13 

k1 = I 1.sooooo 

k2 = I 0. 007800 

OK I I Cancel I 

MICRO DRAINAGE GLOBALS COMMAND 

The Settings > MicroDrainage globals command opens the MicroDrainage Global 

variables dialog box. This dialog box is used to define and save parameter values for 

analyzing and designing a drainage network using standard MicroDrainage modules. This 

~MicroDrainage Global Variables 13 
[ile 

:~~~i~,:< England & Wales 
Return Period: 1 l yrs 

M5-60: I WOOD.. mm 

Ratio R: I 0.400 ... 

Global Time of Entry: I 5.000 

Max Rainfall: I 5 

Foul Sewage per hectare: I 0.000 

Infiltration·% of flow: I 0 

Overflow Setting: ... I □--
Level: Inverts 

Volumetric Runoff Coeff: I 0.750 

min 

mm/hr 

1/s 

Min Backdrop Height: I 0.000 m 

Depth from soffit to G.L.: I 0.000 . m 

Min velocity (auto design): I 1.000 mis 

Max velocity [auto design): I 1.300 mis 

Min slope for optimisation: j 500_ . . (1/x) 



is a two way process. The values, which are stored in a standard stormwater file, are 

exported into MicroDrainage. Upon completion of MicroDrainage analyses and design, the 

stormwater file is imported back to StormWorks. 

VIEW MENU 

The View commands provide the tools necessary to display data stored in digital terrain­

model surfaces and the active coordinate geometry project. These views are for the active 

surface and geometry. Many of these commands can also be accessed using 

StormWorks Palettes menus. 

FIT SURFACE COMMAND 

The View > Fit > Surface command fits a graphic view using graphics associated with the 

active surface. This command is helpful if the graphics associated only with a single 

surface is to be viewed. This command does not fit coordinate geometry graphics into the 

view. In addition, MicroStation graphics in the design file that are a different elevation from 

the surface graphics may not appear. Only one surface can be fit at a time. 

FIT ALIGNMENT COMMAND 

The View > Fit > Alignment command reorients and resizes the selected view about the 

extents of an alignment. Only one alignment can be fit at a time. 
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VIEW PERIMETER COMMAND 

The View > Perimeter command displays the outermost edge of a triangulated digital 

terrain-model. This command is helpful for visualizing the boundaries of the triangulated 

model and for fitting the surface to the viewing screen so that the results of subsequent 

commands can be seen. 

6View Perimeter f3 

VIEW CONTOUR COMMAND 

Preferences fu!mbologv 

:?~r!~~e:: ;:::::de:::m=o 1==== 
Scale: I 1.00 

r Planarize 
Elevation: ... I C-1.C-ID ___ _ 

I Close I 

The View> Contours command generates and displays elevation contours for the active 

surface. This command automatically generates major contours, minor contours, and 

optionally, contour labels in the design file. 

~View Contours El 
Preferences _fulmbologv Setup 

:?~r.f~c::e:: _d_e_m_o1 ___ _. 

Fence Mode: I n:;;ide 
Scale: !.=1=:.o==o===== 

Interval: I 10.00 
Minors per Major: .-I 4-----

r Planarize 

Elevation: I 0.00 

I Close] 
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DEPRESSION CONTOURS COMMAND 

The View > Depression Contours command displays depression contours for the active 

surface. Depression contours incrementally descend the surface and are represented 

with tick marks. 

LABEL CONTOURS COMMANDS 

The View > Label Contours command interactively labels contours in a digital terrain 

model. This command is helpful if one wants to specify where contour labels will appear. 

VIEW TRIANGLES COMMAND 

The View > Triangles command displays all or a portion of the triangles contained within 

the active surface. The triangles are created when the model is triangulated. This 

command is useful after triangulating the data so that the location of surface points can be 

seen. This command can be used to evaluate a model and pinpoint areas that either have 

too many points or too few points. 

VIEW DTM POINT ELEVATIONS COMMAND 

The View > DTM Point Elevations command finds the elevation (z coordinate) of any 

point in the surface. This command automatically annotates an area of the surface, or is 

used to manually identify individual locations on the surface at which to display elevations. 
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VIEW SLOPE VECTORS 

The View > Slope Vectors command displays vector lines and arrowheads to show the 

downhill direction and degrees of slopes at various points throughout a surface. The 

length of each vector is proportional to the slope of the model; longer vectors indicate 

steeper slopes. 

TWO POINT SLOPE COMMAND 

The View > Two Point Slope command is used to display the slope between two points. 

The slope is represented as a linestring based on the active MicroStation text and 

symbology settings. 

VIEW DRAPE SURFACE 

The View > Drape Surface command projects existing MicroStation elements to the 

elevation of the active surface and then redisplays those elements. This command drapes 

lines, linestrings, curves, shapes, arcs, ellipses, and complex strings or shape 

combinations of these elements. Text, nodes, and cells can also be draped. 

VIEW COLOR CODED COMMAND 

The View > Color-Coded commands display a surface in various colors based on the 

elevation of the points in the surface. The surface may be color coded by elevation, slope, 

or aspect. Each of these commands generates MicroStation shape elements and can 

produce a complete ASCII report showing area quantities for each elevation, slope, or 

aspect range. Additionally, when used in conjunction with any of the available 

D-39 



MicroStation rendering commands, the Color-Coded commands yield accurate depictions 

of a site's elevation, slopes, or aspects. 

VIEW ACTIVE ALIGNMENT 

The View > Active Alignment command displays the active horizontal alignment in the 

design file. 

VIEW STATIONING COMMAND 

The View > Stationing command activates the View Stationing dialog box, which 

controls the display of station annotation text along the active horizontal or vertical 

alignment. Stations can be placed along a horizontal or vertical alignment at a specified 

interval. 

ANNOTATE COMMAND 

The View> Annotate command displays labels for attributes, such as height, length, ID, 

invert elevation, contributing area, discharge, and material type for different StormWorks 

drainage structures. 

jJView Annotation f3 

Element Type 

Areas 
Channels 
Culverts 
Inlets 
Manholes 
Pipes 
Pumps 
Utilities 

A,eJ& I . 
Close j 

Styles~-- . I 
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ANNOTATE PROFILE COMMAND 

The View> Annotate Profile command displays labels for attributes such as ID, slope, 

length, and material type of drainage structures and junctions in a selected profile. 

CONTRIBUTING NETWORK COMMAND 

The View > Contributing Network command allows one to view all of the elements that 

contribute to a network. 

PALETTES COMMANDS 

The Palettes commands are used to perform the majority of the graphical placement and 

manipulation functions of StormWorks. These commands display palettes from which a 

wide variety of tools can be chosen to view surface and geometry information. One can 

also place, design, and manipulate drainage structures, compute drainage information, 

create and edit profiles and HEC-2/WSPRO sections, import HEC-2 water surfaces, and 

display hydrologic information. 

MAIN COMMANDS 

The Main palette contains icons that represent all of the StormWorks commands available 

on the Palettes pull-down menu. This provides a shortcut to frequently used commands--­

The Main palette can be displayed rather than going through the Palettes menu. Beneath 

each icon on the Main palette lies the corresponding group of command icons represented 

as tear-off palettes. Options offered are View Surface palette, View Geometry palette, 
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Layout palette, Flow palette, Design palette, Manipulate palette, Profiles palette, and 

HEC/WSPRO palette. 

VIEW SURFACE 

The Palettes > View Surface commands allows one to display the various elements of a 

surface. Elements that can be displayed are perimeter, contours, depression contours, 

label contours, triangles, DTM point elevations, slope vectors, two point slope, drape 

surface, color coded elevations, color coded slopes, color coded aspects, and color coded 

triangles. 

VIEW GEOMETRY 

The Palettes > View Geometry commands control the display and annotation of 

horizontal and vertical alignments, horizontal and vertical stations, 3-D alignments, points, 

and profiles. This command affords control over the alignments and elements to be 

displayed as well as their annotation. Sub-commands are viewing the active alignment 

and stationing and fitting the alignment. 

LAYOUT COMMANDS 

The Palettes > Layout commands allow one to interactively place drainage structures, 

such as pipes, inlets, channels, manholes, and pumps. These commands are usually 

used after a new project design file is set up. This includes defining the active project 

parameters, the minimum and maximum design criteria, and the display characteristics of 
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the structures. After loading and defining the active surface, the Layout commands are 

used to place the structures needed to design the storm drainage system. 

FLOW COMMANDS 

The Palettes > Flow commands allow one to define percentages of land cover and 

compute peak runoff (flow rate) resulting from a storm. These commands are used to 

define the parameters for calculating rainfall intensity and to determine the type of 

equation best suited for computing inlet time of flow. Other features of this command allow 

one to get flow into the system, establish the discharge parameters, compute drainage 

areas and peak runoffs, attach computed drainage areas to a specified structure, highlight 

the attached areas, and highlight inlets not attached to drainage areas. Additionally one 

can attach bypass inlets, compute time of flow, highlight inlets with or without routed 

bypass, and detach the computed area flow or injected flow from a specific structure. 

DESIGN COMMANDS 

The Palettes > Design commands is used to design a new storm drainage system. One 

can design an individual structure or downstream structures that are affected by discharge 

from upstream structures. Additionally this command can be used to analyze pipe design 

characteristics, compute pipe sizes, and analyze channel design characteristics. 

Note that when designing structures, Storm Works displays a warning if design criteria are 

exceeded. If the report lock is toggled on, a dialog box appears displaying the warning 

messages. 
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MAN/PU LA TE COMMANDS 

The Palettes > Manipulate commands is used to fine-tune the drainage network and to 

manipulate and modify the information stored on the StormWorks structures. These 

commands are used to adjust the layout to satisfy the minimum cover criteria, to renumber 

network connections, and to review/edit the structure parameter values. 

PROFILES COMMAND 

The Palettes > Profile commands allow one to work with profiles of the drainage system. 

This command can be used to create a profile of a drainage system, update existing 

profiles, set parameters for and display profile annotation, display graphics where linear 

features intersect a profile, check pipe cover between profile structures, insert manholes 

and inlets into a profile, and move profile structures. 

HECIWESPRO COMMANDS 

The Palettes > HEC/WSPRO commands is used to create HEC-2 and WSPRO channel 

sections, to import HEC-2 and WSPRO water surfaces, and to plot water surface profiles. 

HYDROLOGY COMMANDS 

The Palettes > Hydrology commands allow one to display features, such as contours, 

ridges, flat areas and valleys that affect water flow on the surface of the DTM. One can 

also display flow paths and tributaries and compute the volume of water in retention 

ponds. 
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UTILITIES COMMANDS 

The Utilities commands allow one to perform general design file tasks that are appropriate 

throughout the design cycle, such as manipulating and reviewing the active geometry. 

The Utilities > Active Surface command allows one to designate any existing surface as 

the active surface. The surface should have been created or opened before using this 

command. 

The Utilities > Delete Surface completely deletes a surface and removes the point and 

triangle data associated with the surface. This command is used when incorrect data is 

loaded onto the surface. 

The Utilities > Review Surface command reviews information associated with any 

surface. This command can be used to review the number of points and triangles in a 

surface. Modifications can be made to the name, description and maximum triangle side 

length parameters associated with any surface. 

l;Review Surface 13 

:Surface:: demo 
· N·a-~e·: ;::j d=em=o===== 

Description: I existing ground surface 

Maximum Length: I 0.00 

Material: I Not Defined 

Data Range 
Minimum 

Northing: 11146.31 

Easting: 11627.39 

Elevation: 914.00 

Maximum 

13944.50 

14859.64 

975.20 

Data Totals 

Random: 
Breakline: 

Contour: 
Inferred: 
Interior: 

Exterior: 

Points: 
Triangles: 

I Cancel] 

Active Deleted Total 
7551 0 7551 
882 0 882 

0 0 0 
0 0 0 
0 0 0 
0 0 0 

8433 0 8433 
16774 90 16864 



The Utilities> Channel To Surface command merges the designed channel surface into 

an existing surface. The resulting surface is a fully triangulated new surface containing the 

original surface data plus the channel. 

The Utilities > Triangulate Surface command is used to form or re-form the 3-D faceted 

surface that defines a digital terrain model. Small, triangular plains are created by the 

exercise of this command. 

;}Triangulate Surface El 

Surface: demo 
Maximum Length: ;::I o=.o==o===----' 
r View Triangles 

r · Use Extended Data Checks 

Surface Features ---~ 

r Load Features 
Filter Tolerance: ,-I□-.□-□---

r Empty Existing Surface 

Results 

Number of Points: 

Number of Triangles: 

Elapsed Time (sec): 

8433 
16782 

1 

The Utilities > Active Geometry command changes the active geometry project, 

alignments and superelevation. This command can also be used to display and update 

information. The geometry types that can be activated are Geometry Project, horizontal 

alignment, vertical alignment and superelevation. 
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The Utilities > Delete Geometry command removes from internal memory a geometry 

project, a horizontal alignment or a vertical alignment and all its children, or a 

superelevation. Once such a geometry has been deleted, it is removed from memory and 

is not recoverable. 

The Utilities > Review Geometry command displays information about the geometry of 

the active horizontal alignment. 

The Utilities > Tracking > General command dynamically displays the northing and 

easting coordinates of the cursor location as well as the surface elevation, slope and 

aspect. 

The Utilities > Tracking > Geometry command tracks the cursor along the active 

horizontal alignment and displays the station, offset, and elevation of the alignment in the 

MicroStation Command Window. 

The Utilities > Queries and reports command allows one to locate, modify and generate 

reports on drainage elements using queries. The Query dialog box provides options that 

define the query criteria. Once this command is executed, StormWorks displays the 

graphics that represent all the network elements meeting the query criteria. 
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~Query Editor f3 
File ~mbology 

.......... 
:~1~!11~!1~ T~P.e; Channels 

Attribute Operator Value 

Ace Pnt Flw 

~ 
equal 

~I 
I 1nser£] 

Area Runoff less than or equal 
Bypass From less than 
Chan Time greater than or equal 

~ Criteria 

Attribute Operator Value 

r 
I Delete I 
I And I 
I 0~_1 

I Apply I I Modify] I Report I I Cance!_) 

The Utilities > Maintenance Information command provides for maintaining a service 

record for the structures in the network. The parameters employed are the identification 

number of the selected structure, date the structure was installed, and the date the 

structure was last serviced. 

The Utilities > Promote Micro Drainage command allows for naming the structures in a 

drainage network compatible with the MicroStation naming system. The network can then 

be saved to a .sws file for further analysis. 

The Utilities > DraftWorks command activates the DraftWorks product. 
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